Bug 814620 - kwalletmanager doesn't start
kwalletmanager doesn't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kwallet (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 05:41 EDT by ycollet
Modified: 2013-05-30 15:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 15:06:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ycollet 2012-04-20 05:41:12 EDT
I updated my fedora 16 to the latest release (yum update).
kwalletmanager refuses to start.

Here is the message I've got:

kwalletmanager 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

Best regards,

YC
Comment 1 Kevin Kofler 2012-04-20 06:01:04 EDT
kwalletmanager starts as a hidden system tray icon. Click on the popup arrow at the end of the system tray to see it.
Comment 2 ycollet 2012-04-20 10:31:25 EDT
OK, thanks for the hint, it works.
But I still have a problem:
I can launch kwalletmanager via the KDE menu. When I click on KDE->System->Wallet manager (I am not sure of the translation), nothing happens.
Comment 3 Rex Dieter 2012-04-20 10:35:42 EDT
same thing, look in the hidden items in your systray for it (yes, it's bad upstream behavior imo).
Comment 4 Rex Dieter 2012-04-20 10:38:01 EDT
fwiw, if I'm annoyed enough and have time, I'll hunt through bugs.kde.org for an open issue on that, and if there isn't one yet, I'll file one.
Comment 5 Rex Dieter 2012-04-20 11:01:02 EDT
So, what I'm going to argue upstream is basically:

The app menu item should envoke:
1. kwalletmanager --show
2. --show should actually *do* something if the app is already running (currently it does not)

OR (even better, but this may require more work to get right):

1.  kwalletmanager before should (essentially) run with --show by default when launched interactively (either from command-line, menus, whatever).
2.  and in the autolaunch/launch-on-demand case, kwalletmanager simply *not* --show

either way, everyone should win in this scenario.
Comment 6 ycollet 2012-04-20 11:50:34 EDT
Looks OK to me.

I wanted to open kwalletmanager to disconnect it.
So, when I click on kwalletmanager, I waited for some informations, and nothing happens. So, your solution seems OK to me.

Best regards,

YC
Comment 7 Sam Tuke 2012-09-11 07:22:18 EDT
(In reply to comment #5)
> So, what I'm going to argue upstream is basically:
> 
> The app menu item should envoke:
> 1. kwalletmanager --show
> 2. --show should actually *do* something if the app is already running
> (currently it does not)
> 
> OR (even better, but this may require more work to get right):
> 
> 1.  kwalletmanager before should (essentially) run with --show by default
> when launched interactively (either from command-line, menus, whatever).
> 2.  and in the autolaunch/launch-on-demand case, kwalletmanager simply *not*
> --show
> 
> either way, everyone should win in this scenario.

Agreed. I just spent ten minutes hunting around for a solution to this, even resorting to finding kwallet config files to try and edit a stored username manually (they're encrypted, doh!).

This is a serious usability bug. No visual or commandline output resulting from execution of kwalletmanager implies to the user that nothing has happened, and that the app has silently died.

Using the --show option didn't make any difference, by the way.

Please address this!
Comment 8 Jeff Bastian 2013-05-30 14:21:17 EDT
I'm hitting this in Fedora 19 Beta with kwallet-4.10.3-1.fc19.x86_64, except I don't see any icon anywhere -- not in the task bar, not in the system tray, not in the arrow at the end of the system tray.

The process is running:

$ pgrep -lf kwallet
2474 kwalletd
3831 kwalletmanager

But the hidden system tray arrow only reveals
  Notifications
  Manage Print Jobs
  Software Updater
  Device Notifier
  Battery Monitor

I have to kill the kwalletmanager process and launch it again with --show to actually get it to appear.
Comment 9 Rex Dieter 2013-05-30 14:28:48 EDT
How are you starting kwalletmanager?  Part of your saved session?
Comment 10 Jeff Bastian 2013-05-30 14:32:01 EDT
I was going to suggest adding "--show" to the desktop file, but I see there are four files:

$ rpm -ql kwallet |grep desktop
/usr/share/applications/kde4/kwalletmanager-kwalletd.desktop
/usr/share/applications/kde4/kwalletmanager.desktop
/usr/share/kde4/services/kwalletconfig.desktop
/usr/share/kde4/services/kwalletmanager_show.desktop

And they have different Exec lines:

$ rpm -ql kwallet | grep desktop | xargs grep -h Exec
Exec=kwalletmanager --kwalletd
Exec=kwalletmanager %u
Exec=kcmshell4 kwalletconfig
Exec=kwalletmanager --show


So the /usr/share/kde4/services/kwalletmanager_show.desktop file does include the --show option, but apparently that's not what gets executed when I launch kwalletmanager from the KDE menus since I see nothing on the screen.

Maybe the --show should be added to /usr/share/applications/kde4/kwalletmanager.desktop also?
Comment 11 Jeff Bastian 2013-05-30 14:33:32 EDT
(In reply to Rex Dieter from comment #9)
> How are you starting kwalletmanager?  Part of your saved session?


No, I used the menus.  Using the KDE kickoff menu, I launched it from
   Applications -> System -> Wallet Management Tool
Comment 12 Jeff Bastian 2013-05-30 14:53:09 EDT
(In reply to Jeff Bastian from comment #10)
> Maybe the --show should be added to
> /usr/share/applications/kde4/kwalletmanager.desktop also?


This fixes the problem for me:

--- /usr/share/applications/kde4/kwalletmanager.desktop.ORIG    2013-05-02 23:43:14.000000000 -0500
+++ /usr/share/applications/kde4/kwalletmanager.desktop 2013-05-30 13:51:25.858920830 -0500
@@ -113,7 +113,7 @@
 GenericName[x-test]=xxWallet Management Toolxx
 GenericName[zh_CN]=钱包管理工具
 GenericName[zh_TW]=錢包管理工具
-Exec=kwalletmanager %u
+Exec=kwalletmanager --show %u
 MimeType=application/x-kwallet;
 InitialPreference=6
 Icon=kwalletmanager


I can now launch the wallet manager from the KDE kickoff menu and the window appears.
Comment 13 Jeff Bastian 2013-05-30 14:55:56 EDT
From the wallet manager, I went to Settings -> Configure Wallet and I disabled the checkbox for "Show manager in system tray".  Now I can run kwalletmanager without the --show option and the window appears also.

There seems to be a bug causing the system tray icon to go missing.
Comment 14 Rex Dieter 2013-05-30 14:58:11 EDT
if on f19, then it's likely qt-4.8.4-18.fc19, see bug #968794
Comment 15 Jeff Bastian 2013-05-30 15:06:17 EDT
Oh, you're right!  I hadn't noticed, but the mixer icon is also missing.  I'll close this and let bug 968794 handle it.
Comment 16 Jeff Bastian 2013-05-30 15:18:05 EDT
I downgraded to qt-4.8.4-17.fc19.x86_64 (from -18.fc19) and that fixed the problem: the wallet manager icon is back in the hidden system tray, along with kmix and klipper and more.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.