Bug 814754 - Monitor thin metadata usage and extend automatically to avoid running out
Monitor thin metadata usage and extend automatically to avoid running out
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
Unspecified Linux
medium Severity medium
: rc
: 6.4
Assigned To: Zdenek Kabelac
Cluster QE
: FutureFeature
Depends On: 814831
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 11:15 EDT by Alasdair Kergon
Modified: 2014-11-26 02:36 EST (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.111-2.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-26 02:36:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2012-04-20 11:15:07 EDT
Monitor the kernel's thin pool metadata usage, and it exceeds a specified threshold, extend it.
Comment 1 RHEL Product and Program Management 2012-07-10 02:07:42 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:57:08 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Corey Marthaler 2012-07-26 15:29:03 EDT
QE reviewed this BZ for QA_ACK but was unable to ack due to a lack of
requirements or description of how the new feature is supposed to work or be
tested.

Please see
https://wiki.test.redhat.com/ClusterStorage/WhyNoAck
Comment 4 Corey Marthaler 2012-08-09 13:53:21 EDT
QA planning phase ends Aug 10th (tomorrow), without more information this feature will likely be nacked by QA.

https://engineering.redhat.com/program/rhel/rhel-6-4-0/
Comment 5 Zdenek Kabelac 2012-08-10 07:59:26 EDT
While we have the preliminary testing code for lvm part the kernel part is still not finished.

So the test for this bugzilla should focus on testing corner-case behavior when metadata device will get full.

In the ideal case the pool should switch itself into read-only mode and data stored in pool should remain readable while any new write should fail.
Comment 6 Corey Marthaler 2012-08-15 18:13:15 EDT
Adding QA ack for 6.4.

Devel will need to provide unit testing results however before this bug can be
ultimately verified by QA.
Comment 7 Zdenek Kabelac 2012-10-11 05:54:31 EDT
Feature is not yet ready, postponing to the next release.
Comment 13 Zdenek Kabelac 2014-11-25 13:07:16 EST
Monitoring of metadata volumes and its automatic online resize should be available with version 2.02.106 and newer and thin-pool target >=1.10

It's controlled with lvm.conf  global/thin_pool_autoextend_threshold option.

Note You need to log in before you can comment on or make changes to this bug.