Bug 814764 - [RFE] Support 64-bit numbers of extents
Summary: [RFE] Support 64-bit numbers of extents
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: LVM and device-mapper
Classification: Community
Component: lvm2
Version: 0-beta1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: LVM and device-mapper development team
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
: 815181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-20 15:25 UTC by Alasdair Kergon
Modified: 2019-10-28 15:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-28 15:50:04 UTC
rule-engine: lvm-technical-solution?
rule-engine: lvm-test-coverage?


Attachments (Terms of Use)

Description Alasdair Kergon 2012-04-20 15:25:55 UTC
Currently the number of extents in any LV is limited to 32 bits.  Large LVs use large extent sizes.

But with thin, mostly sparse, LVs, there comes a need for large LVs to have small extent sizes.

Consider compatibility, perhaps limiting this to thin LVs in the first instance.

Comment 1 Milan Broz 2012-04-23 06:10:14 UTC
*** Bug 815181 has been marked as a duplicate of this bug. ***

Comment 2 Tom Lavigne 2012-09-07 15:21:47 UTC
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.

Comment 8 Heinz Mauelshagen 2016-07-27 17:26:03 UTC
We do map (small) thin chunks onto a thin pool DataLV with the current solution and keep track of their mapping on a thin MetaLV managed by the thin target, hence we don't require 64 bit extent numbers any more -> closing.

Feel free to reopen in case another requirement arises.

Comment 9 Zdenek Kabelac 2016-07-27 22:41:32 UTC
The reason why to support this is quite simple -

When you create 'small' extent size - you can't create large volume size -  so the comment 8 is not really relevant.

With 4MB extent you cannot create  4EB  thin volume - even though there is not other technical limitation -  the total size of LV is still expressed as 32bit * 32bit number.

Comment 10 Jonathan Earl Brassow 2019-10-28 15:50:04 UTC
I don't see us getting to this self-imposed feature.  I've also heard no requests for this from customers...


Note You need to log in before you can comment on or make changes to this bug.