Bug 814765 - %makeinstall doesn't set ${htmldir}
%makeinstall doesn't set ${htmldir}
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 11:32 EDT by David Woodhouse
Modified: 2012-05-08 07:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 07:58:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2012-04-20 11:32:41 EDT
We don't seem to set DESTDIR when running 'make install'. Instead, the %makeinstall macro overrides a bunch of the standard directories that autoconf sets. 

With openconnect configured with
%configure --htmldir=%{_docdir}/%{name}-%{version}

...installation fails, because it ends up trying to install into the root instead of into $RPM_BUILD_ROOT. If we were using DESTDIR for installation, this would have worked fine... isn't that what DESTDIR is *for*?

I've worked around it by setting --htmldir='${datadir}/doc/%{name}-%{version}', so that $datadir is expanded by make at 'make install' time, and does pick up the value that's overridden by %makeinstall. But that doesn't seem right...
Comment 1 Panu Matilainen 2012-04-21 01:57:32 EDT
http://fedoraproject.org/wiki/Packaging:Guidelines#Why_the_.25makeinstall_macro_should_not_be_used

All current Fedora versions support %make_install macro which does the "right thing":

%make_install %{__make} install DESTDIR=%{?buildroot}
Comment 2 Panu Matilainen 2012-05-08 07:58:28 EDT
WONTFIX, like noted %makeinstall is plain broken and only kept around for backwards compatibility, new packages shouldn't use it at all so there's little reason to "fix" it to work with newer auto*tools.

Note You need to log in before you can comment on or make changes to this bug.