Bug 814792 - Replication errors when CS and DS share a database
Replication errors when CS and DS share a database
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Linux_Domain_Identity_Management_Guide (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Aneta Šteflová Petrová
Namita Soman
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 13:08 EDT by Deon Ballard
Modified: 2015-03-10 08:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-10 08:05:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2012-04-20 13:08:31 EDT
This is something that we need to revisit when the CS and IPA start sharing same DS instance. 

 https://bugzilla.redhat.com/show_bug.cgi?id=750529 

Description of problem:
After CS replication is removed, replica can see a new host is issued a cert,
but doesn't have a copy of it, and throws a serial number error.

In response to a test case to do this, Rob's response:
I wonder if we should doc this. What is happening is the host is
replicating through a different channel, so we can see it. Because the
CS replication was removed we can see that the host has been issued a
valid certificate from our CA but our local install doesn't have a copy
of it, hence the serial # error.

This and a few others point out some pretty scary problems related to
certificate replication, this isn't something people should take lightly.

Version-Release number of selected component (if applicable):
ipa-server-2.1.3-6.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.Install master, replica
2.Install CS server on replica
3.Delete the replication agreement, and the data from replica
# ipa-csreplica-manage del ipa-replica1.testrelm -p XXX
4. Add a host, add cert to a host from master
5. Check settings for this host from replica

Actual results:
Error that host?s cert cannot be found:
Certificate operation cannot be completed: EXCEPTION (Certificate serial number
0x2d not found)

Expected results:
if this is doc'd, the user will know to check CS replication, and be prepared.
Comment 1 Deon Ballard 2012-04-20 13:09:26 EDT
This is from https://fedorahosted.org/freeipa/ticket/2047.
Comment 2 Deon Ballard 2012-11-07 16:57:26 EST
This is not in RHEL 6.4. Unsetting the flags.
Comment 4 Deon Ballard 2013-02-06 14:34:52 EST
Changing to RHEL 7.
Comment 8 Scott Poore 2015-02-12 14:36:54 EST
document verified.

Note You need to log in before you can comment on or make changes to this bug.