Bug 814901 - dump-capture kernel fails to boot at setting up new root fs
dump-capture kernel fails to boot at setting up new root fs
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
Depends On:
  Show dependency treegraph
Reported: 2012-04-21 02:39 EDT by bolt liu
Modified: 2017-11-06 21:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-03 08:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
outputs of capture kernel which fails to boot (14.12 KB, text/plain)
2012-04-21 02:39 EDT, bolt liu
no flags Details

  None (edit)
Description bolt liu 2012-04-21 02:39:28 EDT
Created attachment 579154 [details]
outputs of capture kernel which fails to boot

Description of problem:
fail to boot capture kernel after:
echo c > /proc/sysrq-trigger

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install the RPMs(shown above);
2. add crashkernel=256M@16M in the grub.conf (I had tried 64M@16M before 256M@16M, the same failure), boot the installed kernel
3. load the kernel with (/dev/hda3 is mounted as /):
/usr/sbin/kexec -p vmlinuz-2.6.18-308.1.1.el5debug --initrd=initrd-2.6.18-308.1.1.el5debug.img --args-linux --append="root=/dev/hda3 console=ttyS1,19200 TERM=ansi-generic init 3 irqpoll"
4. crash the kernel with:
   echo c > /proc/sysrq-trigger
5. the capture kernel starts to boot, but it fails like:
   EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting inKernel panic - not syncing: Attempted to kill init!
 ernal defaults
 Switching to n

Actual results:
fail to boot

Expected results:
boot without error

Additional info:
1. I am using the relocatable feature (the same kernel as the system kernel and capture kernel);
2. please see the detailed outputs in the attachment.
Comment 1 RHEL Product and Program Management 2014-03-07 07:45:14 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:25:28 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 3 bolt liu 2017-11-06 21:16:08 EST
I still got the following messages:
"The following is a list of bugs or attachments to bugs in which a user has been waiting more than 7 days for a response from you. Please take action on these requests as quickly as possible. (Note that some of these bugs might already be closed, but a user is still waiting for your response.)

We'll remind you again in another 7 days if these requests are still outstanding, or if there are any new requests where users have been waiting more than 7 days for your response.


how should i proceed on this?

Note You need to log in before you can comment on or make changes to this bug.