Bug 814908 - vlc.i686 not compatible in EPEL
vlc.i686 not compatible in EPEL
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: yum (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Sheltren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 05:09 EDT by Andres Rios
Modified: 2013-05-30 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 05:07:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andres Rios 2012-04-21 05:09:41 EDT
Description of problem:
Error while updating

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. before installing epel repositories I installed vlc.i686 (VLC media player)
2. install epel repositories
3. yum update
  
Actual results:
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                         |  17 kB     00:00     
 * base: mirror.majorhost.net
 * epel: mirror.yandex.ru
 * extras: mirror.majorhost.net
 * rpmforge: fr2.rpmfind.net
 * updates: mirror.majorhost.net
epel                                                                                                                                                  | 4.0 kB     00:00     
epel/primary_db                                                                                                                                       | 3.6 MB     00:01     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dirac.i686 0:1.0.2-1.el6.rf will be updated
--> Processing Dependency: libdirac_decoder.so.0 for package: dirac-1.0.2-4.el6.i686
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc-1.1.13-1.el6.rf.i686
--> Processing Dependency: libdirac_encoder.so.0 for package: dirac-1.0.2-4.el6.i686
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc-1.1.13-1.el6.rf.i686
--> Processing Dependency: libdirac_encoder.so.0 for package: ffmpeg-0.6.5-1.el6.rf.i686
---> Package dirac.i686 0:1.0.2-4.el6 will be an update
---> Package enca.i686 0:1.10-1.el6.rf will be updated
---> Package enca.i686 0:1.13-1.el6 will be an update
---> Package fribidi.i686 0:0.10.9-1.el6.rf will be updated
---> Package fribidi.i686 0:0.19.2-2.el6 will be an update
---> Package fuse-sshfs.i686 0:2.2-1.el6.rf will be updated
---> Package fuse-sshfs.i686 0:2.3-1.el6 will be an update
---> Package geany.i686 0:0.20-1.el6.rf will be updated
---> Package geany.i686 0:0.21-1.el6 will be an update
---> Package libass.i686 0:0.9.11-1.el6.rf will be updated
---> Package libass.i686 0:0.10.0-1.el6 will be an update
---> Package libcaca.i686 0:0.99-0.1.beta17.el6.rf will be updated
---> Package libcaca.i686 0:0.99-0.9.beta16.el6 will be an update
---> Package libcddb.i686 0:1.3.1-1.el6.rf will be updated
---> Package libcddb.i686 0:1.3.2-2.el6 will be an update
---> Package libdvdnav.i686 0:0.1.10-3.el6.rf will be updated
---> Package libdvdnav.i686 0:4.1.4-0.1.svn1184.el6 will be an update
---> Package libkate.i686 0:0.3.7-1.el6.rf will be updated
---> Package libkate.i686 0:0.3.8-1.el6 will be an update
---> Package libmodplug.i686 0:0.8.7-1.el6.rf will be updated
--> Processing Dependency: libmodplug.so.0 for package: vlc-1.1.13-1.el6.rf.i686
---> Package libmodplug.i686 1:0.8.8.3-2.el6 will be an update
---> Package libupnp.i686 0:1.6.6-1.el6.rf will be updated
--> Processing Dependency: libthreadutil.so.2 for package: vlc-1.1.13-1.el6.rf.i686
--> Processing Dependency: libupnp.so.3 for package: vlc-1.1.13-1.el6.rf.i686
---> Package libupnp.i686 0:1.6.13-1.el6 will be an update
---> Package orc.i686 0:0.4.11-1.el6.rf will be updated
---> Package orc.i686 0:0.4.16-6.el6 will be an update
---> Package p7zip.i686 0:9.20.1-1.el6.rf will be updated
---> Package p7zip.i686 0:9.20.1-2.el6 will be an update
---> Package portaudio.i686 0:19-1.20071207.el6.rf will be updated
---> Package portaudio.i686 0:19-9.el6 will be an update
--> Processing Dependency: libjack.so.0 for package: portaudio-19-9.el6.i686
---> Package svgalib.i686 0:1.9.25-1.el6.rf will be updated
---> Package svgalib.i686 0:1.9.25-8.el6 will be an update
---> Package zvbi.i686 0:0.2.33-2.el6.rf will be updated
---> Package zvbi.i686 0:0.2.33-6.el6 will be an update
--> Running transaction check
---> Package dirac-libs.i686 0:1.0.2-4.el6 will be installed
---> Package jack-audio-connection-kit.i686 0:0.118.0-1.el6 will be installed
---> Package libmodplug.i686 0:0.8.7-1.el6.rf will be updated
--> Processing Dependency: libmodplug.so.0 for package: vlc-1.1.13-1.el6.rf.i686
---> Package libupnp.i686 0:1.6.6-1.el6.rf will be updated
--> Processing Dependency: libthreadutil.so.2 for package: vlc-1.1.13-1.el6.rf.i686
--> Processing Dependency: libupnp.so.3 for package: vlc-1.1.13-1.el6.rf.i686
--> Finished Dependency Resolution
Error: Package: vlc-1.1.13-1.el6.rf.i686 (@rpmforge)
           Requires: libthreadutil.so.2
           Removing: libupnp-1.6.6-1.el6.rf.i686 (@rpmforge)
               libthreadutil.so.2
           Updated By: libupnp-1.6.13-1.el6.i686 (epel)
               Not found
Error: Package: vlc-1.1.13-1.el6.rf.i686 (@rpmforge)
           Requires: libmodplug.so.0
           Removing: libmodplug-0.8.7-1.el6.rf.i686 (@rpmforge)
               libmodplug.so.0
           Updated By: 1:libmodplug-0.8.8.3-2.el6.i686 (epel)
               Not found
Error: Package: vlc-1.1.13-1.el6.rf.i686 (@rpmforge)
           Requires: libupnp.so.3
           Removing: libupnp-1.6.6-1.el6.rf.i686 (@rpmforge)
               libupnp.so.3
           Updated By: libupnp-1.6.13-1.el6.i686 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
normal updating

Additional info:
[root@localhost mylogin]#  yum info vlc.i686
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.majorhost.net
 * epel: mirror.yandex.ru
 * extras: mirror.majorhost.net
 * rpmforge: ftp-stud.fht-esslingen.de
 * updates: mirror.majorhost.net
Installed Packages
Name        : vlc
Arch        : i686
Version     : 1.1.13
Release     : 1.el6.rf
Size        : 50 M
Repo        : installed
From repo   : rpmforge
Summary     : The VideoLAN client, also a very good standalone video player
URL         : http://www.videolan.org/
License     : GPL
Description : VideoLAN Client (VLC) is a highly portable multimedia player for various
            : audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
            : well as DVDs, VCDs, and various streaming protocols.
            : 
            : Available rpmbuild rebuild options :
            : --with mga pth mozilla
            : --without dvdread dvdnav dvbpsi v4l avi asf aac ogg mad ffmpeg cdio
            :           a52 vorbis mpeg2dec flac aa caca esd alsa xosd
            :           lsp lirc id3tag faad2 theora mkv modplug smb speex glx x264
            :           gnomevfs vcd daap upnp pvr live portaudio avahi hal glide
            :           ncurses
            : 
            : Options that would need not yet existing add-on packages :
            : --with loader ggi tarkin tremor
Comment 1 Panu Matilainen 2013-05-30 05:07:05 EDT
Mixing up 3rd party repositories needs to be done with care, many of them are mutually incompatible, causing issues like this. See eg the "Third Party Repositories" section from http://wiki.centos.org/AdditionalResources/Repositories for some hints how to deal with this, but the best option is to avoid mixing incompatible repositories in the first place.

Not a yum bug however.

Note You need to log in before you can comment on or make changes to this bug.