Bug 814948 - consider bumping epoch for libsmbclient/libwbclient upgrade path
consider bumping epoch for libsmbclient/libwbclient upgrade path
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 10:24 EDT by Kalev Lember
Modified: 2013-08-01 16:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: samba-3.6.5-86.fc17.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 16:06:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of dependencies for libsmbclient (8.94 KB, text/plain)
2012-04-26 02:50 EDT, Steve
no flags Details

  None (edit)
Description Kalev Lember 2012-04-21 10:24:05 EDT
A samba4 update that was available in F17 and rawhide repositories replaced the samba 3.x versions of libsmbclient/libwbclient, upgrading them to:

1:libsmbclient-4.0.0-41alpha18.fc17.x86_64
1:libwbclient-4.0.0-41alpha18.fc17.x86_64

Please consider bumping epoch on the samba 3 package from 1 to 2, so that users who managed to update to samba4 versions of libsmbclient/libwbclient could get the samba 3 versions back.

https://bugzilla.redhat.com/show_bug.cgi?id=814451
Comment 1 Andreas Schneider 2012-04-23 05:24:41 EDT
Yes, it was a mistake to package libsmbclient and libwbclient, but I don't see why this should be necessary to bump the Epoch. If the package manager isn't able to handle a downgrade correctly then I would say yum has a bug.
Comment 2 Kalev Lember 2012-04-25 17:44:29 EDT
Our tools expect that package versions always go up. 'yum update' deliberately only handles version updates, not downgrades.

In order to break this cycle and to make it possible to do version downgrades, there's the Epoch. Adding Epoch trumps all other version comparison, so with Epoch bumps it's possible to go backwards with the version.

What is happening is that a lot of users have the samba4 version of libsmbclient installed. In F17, updates-testing is enabled by default, so the faulty update really got to everyone who has F17 installed.

The current situation is this.
Installed: 
libsmbclient 1:4.0.0-41alpha18.fc17

available in repos:
libsmbclient 1:3.6.4-84.fc17.1

With this information, yum decides that what the users have installed (1:4.0.0) is newer than what's in the repos (1:3.6.4) and doesn't do anything. The fix would be bumping the epoch; that way 2:3.6.4 > 1:4.0.0 and users get the correct package.

Another complication is that the faulty libsmbclient package also Requires: samba4-common = 1:4.0.0-41alpha18.fc17. When there's a version upgrade available to samba4-common, yum will detect a problem: it will try to update samba4-common, but the depsolving will fail because an installed package requires a specific older version of samba4-common.

Bumping epoch here would be a courtesy to users who aren't well-versed in rpm versioning and don't know how to handle the situation themselves.
Comment 3 Steve 2012-04-26 02:50:25 EDT
Created attachment 580374 [details]
log of dependencies for libsmbclient

this list is ridiculous, the smb client package should almost no dependencies and deletion should not take out most of the graphical desktop system if removed.
Comment 4 Andreas Schneider 2012-04-26 02:58:52 EDT
Getting Samba4 correctly packaged and conflicting with a package which has and Epoch was a real pain and took quite some time. I don't want to start to deal with another epoch update.

Fedora just reached the beta status and I think someone who runs a beta version is someone who is able to solve such a conflict. I would understand if this is already a release candidate and the package would have been in the stable repo.

Install the libsmbclient version which is still in the repository. libsmbclient-3.6.4-84.fc17.1 and everything will be fine. Same for libwbclient.
Comment 5 Ankur Sinha (FranciscoD) 2012-05-01 09:01:31 EDT
Hello,

Please fix this. A smooth upgrade path is a must. The Epoch is there for fixing exactly this kind of issues. :)

Thanks,
Ankur
Comment 7 Fedora End Of Life 2013-07-04 03:43:27 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2013-08-01 16:06:34 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.