Bug 814951 - Upgrade from F16 -> F17 Beta breaks Intel Centrino Ultimate-N 6300 WiFi
Summary: Upgrade from F16 -> F17 Beta breaks Intel Centrino Ultimate-N 6300 WiFi
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: iwl6000-firmware
Version: 17
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-21 14:35 UTC by Tobias Vogel
Modified: 2012-05-07 07:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-07 07:10:05 UTC
Type: Bug


Attachments (Terms of Use)
Output of dmesg, iwconfig, nm-tool (2.50 KB, text/plain)
2012-04-21 14:35 UTC, Tobias Vogel
no flags Details
complete dmesg output (59.06 KB, text/plain)
2012-04-24 20:05 UTC, Tobias Vogel
no flags Details

Description Tobias Vogel 2012-04-21 14:35:22 UTC
Created attachment 579190 [details]
Output of dmesg, iwconfig, nm-tool

Description of problem:
After Upgrade from F16 -> F17 Beta, the previously working Centrino-builtin Ultimate-N 6300 WiFi is broken.

Version-Release number of selected component (if applicable):
Don't actually know how to find component being responsible for failure

How reproducible:
Upgrade from F16 using YUM according to the guide at http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_16_-.3E_Fedora_17

Steps to Reproduce:
1. Convert filesystem
2. Upgrade
3. reboot
  
Actual results:
Wifi broken

Expected results:
Wifi working as before upgrade

Additional info:
System is Samsung NP900X3A Ultrabook

Comment 1 John W. Linville 2012-04-23 14:38:48 UTC
Can we see the complete dmesg output?

Can you be more specific about the problem?  "Wifi broken" may seem descriptive, but it really doesn't point in any particular direction.

Comment 2 Tobias Vogel 2012-04-24 18:39:22 UTC
I'll send the complete dmesg output later the day.

It's actually quite strange, it really looks like the interface just doesn't come up.
Obviously it's detected correctly but the NetworkManager just says wireless network was not ready.

Comment 3 Tobias Vogel 2012-04-24 20:05:42 UTC
Created attachment 579982 [details]
complete dmesg output

Comment 4 Tobias Vogel 2012-05-06 13:32:08 UTC
Problem has gone since the last yum update.

Comment 5 Stanislaw Gruszka 2012-05-07 07:10:05 UTC
Closing per above comment.


Note You need to log in before you can comment on or make changes to this bug.