Bug 814956 - Custom install of fc17 beta will not boot and kills boots of fc16, fc15, fc14
Custom install of fc17 beta will not boot and kills boots of fc16, fc15, fc14
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 11:42 EDT by Fred J. Tydeman
Modified: 2013-05-07 19:14 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-07 19:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.storage.log (654.53 KB, text/x-log)
2012-05-08 20:31 EDT, Steven Usdansky
no flags Details
anaconda.program.log (287.43 KB, text/plain)
2012-05-08 20:33 EDT, Steven Usdansky
no flags Details
program log (218.98 KB, text/plain)
2012-05-08 20:37 EDT, Fred J. Tydeman
no flags Details
storage log (838.37 KB, text/plain)
2012-05-08 20:38 EDT, Fred J. Tydeman
no flags Details

  None (edit)
Description Fred J. Tydeman 2012-04-21 11:42:16 EDT
Description of problem:
Used liveCD to install fc17 beta to a custom layout via a USB memory stick
created via liveusb-creator.
Install appeared to have worked, but when I try to boot, all I get is GRUB on the screen.  Also, when I try to boot other Linux systems on the disk, they all die.  Boot loader is NOT in MBR, but is in / of fc17.

Version-Release number of selected component (if applicable):
fc 17 beta for 32-bit Intel x86

 
Actual results:
fc17 boot starts, but dies with GRUB on screen.
Existing fc16 boot starts, get GRUB menu to choose system, but then get 
many messages about xxx failed.  System hangs before window manager comes up.
Same with fc15 and fc14.  Had to restore from backups fc14, fc15, fc16, which
now work.

Expected results:
fc17, fc16, fc15, fc14 would boot.

Additional info:
/dev/sda1 = Windows Vista (not used in custom layout)
/dev/sda2 = Sun Solaris (not used in custom layout)
/dev/sda3 = OS/2 boot manager (not used in custom layout)
/dev/sda4 = Extended
/dev/sda5 = /spare5 (formated by fc17 as ext4)
/dev/sda6 = swap (formated by fc17 as swap)
/dev/sda7 = / (formated by fc17 as ext4)
/dev/sda8 = /fedora16 (just mount point to fc17)
/dev/sda9 = /fedora15 (just mount point to fc17)
/dev/sda10= /fedora14 (just mount point to fc17)
/dev/sda11= /lindata (just mount point to fc17)
/dev/sda12= fat16 (not used in custom layout)
/dev/sda13= fat16 (just mount point /data2 to fc17)
/dev/sda14= fat16 (not used in custom layout)
/dev/sda15= fat32 (just mount point /data3 to fc17)
/dev/sda16= hpfs (not used in custom layout)
rest of disk (another 6 or so partitions) not used in custom layout.

Using fc16 to look at the fc17 partition, I notice that
/fc17/boot/grub2/device.map has
 (hd0) /dev/sda
 (hd0,msdos7) /dev/sda7
while fc16 has
 (hd0) /dev/sda
 (hd0,8) /dev/sda8

I will try another install, but this time choose just / and swap in the custom
layout.
Comment 1 Fred J. Tydeman 2012-04-21 14:54:58 EDT
Install from LiveCD using custom configuration to just / and swap resulted in a
fc17 system that will not boot.  Just GRUB appears on the screen.  At least this
time, the other FC systems were left alone and continue to boot.
Comment 2 Fred J. Tydeman 2012-04-21 16:07:36 EDT
In my fc15 system, I added an entry for fc17 to grub.conf.  I booted fc15 and
picked fc17 from the grub menu.  That booted fc17 where I did the first boot
stuff.  So, it appears that the LiveCD installs a bad grub2 configuration.
Comment 3 Fred J. Tydeman 2012-04-21 18:18:21 EDT
I see that the problem of booting fc17 and getting just "GRUB" on the display
is a duplicate of bug 804835.

But, the fact that an install to hard disk from LiveCD made other Fedora
partitions unbootable is a new bug and a potential beta blocker.
Comment 4 Steven Usdansky 2012-04-23 08:46:03 EDT
Description of problem:
Installed from Fedora-17-Nightly-20120416.08-x86_64-Live-lxde.iso with grub in / of F17. I use a custom partitioning scheme with legacy grub in the MBR pointing to a boot partition (/dev/sda2) from which F16's and F17's grub2 in chainloaded. Will not boot. Manual editing of F16's /boot/grub2/grub.cfg file to include an entry for F17 enabled me to boot.
Comment 5 David Lehman 2012-05-07 21:03:48 EDT
Please attach /var/log/anaconda/anaconda.storage.log and /var/log/anaconda/anaconda.program.log to this bug (one at a time and as type text/plain). Thanks.
Comment 6 Steven Usdansky 2012-05-08 20:31:38 EDT
Created attachment 583089 [details]
anaconda.storage.log

anaconda.storage.log
Comment 7 Steven Usdansky 2012-05-08 20:33:23 EDT
Created attachment 583090 [details]
anaconda.program.log
Comment 8 Fred J. Tydeman 2012-05-08 20:37:47 EDT
Created attachment 583091 [details]
program log
Comment 9 Fred J. Tydeman 2012-05-08 20:38:24 EDT
Created attachment 583092 [details]
storage log
Comment 10 Fred J. Tydeman 2012-05-08 21:46:07 EDT
Since those logs are from my 2nd install (the one where I only used / and swap),
it is not clear how much they will help.

Also, I think I have /dev/sda3 and /dev/sda4 backwards.  The IBM OS/2 boot 
manager (a primary partition) is the last cylinder of the disk, so would be sda4.
Comment 11 David Lehman 2012-05-09 10:30:36 EDT
(In reply to comment #4)
> Description of problem:
> Installed from Fedora-17-Nightly-20120416.08-x86_64-Live-lxde.iso with grub in
> / of F17. I use a custom partitioning scheme with legacy grub in the MBR
> pointing to a boot partition (/dev/sda2) from which F16's and F17's grub2 in
> chainloaded. Will not boot. Manual editing of F16's /boot/grub2/grub.cfg file
> to include an entry for F17 enabled me to boot.

Correct me if I'm wrong, but you want to boot a bootloader in the MBR, have it
chainload the F16 grub, which in turn chainloads F17 grub?

Any time you install the F17 bootloader to a partition, the task of adding an
entry to your main bootloader to chainload the F17 bootloader is on you. The
fedora installer will not modify bootloader configurations outside of what it
has been instructed to modify/configure.
Comment 12 David Lehman 2012-05-09 10:49:35 EDT
(In reply to comment #3)
> I see that the problem of booting fc17 and getting just "GRUB" on the display
> is a duplicate of bug 804835.
> 
> But, the fact that an install to hard disk from LiveCD made other Fedora
> partitions unbootable is a new bug and a potential beta blocker.

Can you explain a bit more what exactly is not working that was previously working? Did it break your main (MBR) bootloader so that it cannot load itself? Or, does it appear to have altered its configuration such that it no longer knows how to find/load the other OSes? Or, are you saying that it still knows where/how to load those other OSes but the boot block and/or /boot directory of those other OSes has somehow been altered?
Comment 13 Fred J. Tydeman 2012-05-09 11:44:04 EDT
The MBR bootloader (IBM's OS/2 bootloader that takes one cylinder in a primary
partition) still worked.  From it, I could pick Windows, OS/2, Solaris,
and fc14, fc15, fc16, fc17.  Windows, OS/2 and Solaris still could be booted.
Picking fc17 got just GRUB on the screen (bug 804835).  Picking any of fc14,
fc15, fc16 got a GRUB menu to pick an OS to boot.  When I picked the latest
kernel for any of fc14, fc15, fc16, I got (after pressing Alt-D) many error
messages about things not found.  And a window manager would not start.
So, it appears that the install of fc17 altered the /boot in each of fc14,
fc15, fc16.  This only happened when I told the installer of fc17 about swap,
/, /fc14, /fc15, /fc16, and some data partitions.

My workaround for bug 804835 is to have fc15 load a kernel and ramfs (not
chainload) of fc17.  I understand grub of fc15 so can edit the config file.
I do not understand grub2 of fc16, so leave its config file alone.
Comment 14 Brian Lane 2013-05-07 19:14:31 EDT
I think your setup is a bit too complex for us to support.

Note You need to log in before you can comment on or make changes to this bug.