Bug 814963 - Package lets Eclipse update fail when installed
Package lets Eclipse update fail when installed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-wtp-servertools (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vladimir Kostadinov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 12:23 EDT by Bas Mevissen
Modified: 2012-05-07 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 02:57:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bas Mevissen 2012-04-21 12:23:52 EDT
Description of problem:
When installed, Eclipse update fails with the following message:

Cannot complete the install because one or more required items could not be found.
  Software being installed: WST Server UI 3.3.1.201111171017 (org.eclipse.wst.server_ui.feature.feature.group 3.3.1.201111171017)
  Missing requirement: WST Server Core 3.3.1.201111171017 (org.eclipse.wst.server_core.feature.feature.group 3.3.1.201111171017) requires 'org.eclipse.wst.server.core [1.1.303.201111171017]' but it could not be found
  Cannot satisfy dependency:
    From: WST Server UI 3.3.1.201111171017 (org.eclipse.wst.server_ui.feature.feature.group 3.3.1.201111171017)
    To: org.eclipse.wst.server_core.feature.feature.group [3.3.1.201111171017]

Version-Release number of selected component (if applicable):
eclipse-wtp-servertools-3.3.1-2.fc16.noarch

How reproducible:
100%

Steps to Reproduce:
Package eclipse-wtp-servertools-3.3.1-2.fc16.noarch is installed, start Eclipse and try to update. Problem disappears when uninstalling package and reappears again after installing it again.
  
Actual results:
Error message as show above. Must unselect WST Server Core, UI and User Documentation update boxes to have Eclipse update proceed.

Expected results:
No error message and no update for these components as they are distro supplied.

Additional info:
I've quite some Eclipse packages installed, including eclipse-wst-*
I've check that no old versions of this package are floating around. There are no non-distro files in /usr/share/eclipse/ subtree.
Comment 1 Alexander Kurtakov 2012-04-26 10:41:10 EDT
How do you try to update? Using the internal eclipse update? It's never a good idea do mix rpm and update site for the same plugin.
Comment 2 Bas Mevissen 2012-04-26 11:37:43 EDT
Yes, using the Eclipse intenal update. I was under the impression that the plugins installed as a package would simply be excluded from that internal update. Plugins from rpm packages should only get their updates from the yum repository.
A functional internal Eclipse update is needed as one might install additional plugins. In my case the Android plugin.
Comment 3 Alexander Kurtakov 2012-04-26 12:25:17 EDT
So in this case it's the org.eclipse.wst.server.ui missing from Fedora being the problem, right? Can you try on Fedora 17 as this should be fixed as I installed Android tools without a problem on F-17 alpha a month ago?
Comment 4 Bas Mevissen 2012-04-27 02:16:55 EDT
I can do that after next week. But I'm curious what that would bring. I don.t see any relation with the Android plugin. The problem is with the wst server tools on Fedora 16 and apparently not on 17. So maybe a quick compare between the fc16 and fc17 packages by an expert might reveal the problem (I'm currently travelling).
Comment 5 Bas Mevissen 2012-05-05 18:42:25 EDT
F17 seems fine here as well. So what worked on F17 should go to F16 as well.
Comment 6 Alexander Kurtakov 2012-05-07 02:57:49 EDT
This is not as easy as said because in F17 we have the whole eclipse stack updated and doing that for F16 will be major disruption because of the number of updates needed - every eclipse* package + a number of underlying libraries.
Closing the bug as next release as doing this kind of updates will actually make F16 become F17 from Java POV.
Comment 7 Bas Mevissen 2012-05-07 09:12:47 EDT
So there are basically two workarounds:
1) Deselect the packages in the Eclipse update dialog to be able to update non-packages eclipse plugins
2) Remove the package from the system when you don't need it.

(2a: one might install the package from a different source, untested)

Thanks for looking into this problem and giving the clarification for the closure.

Note You need to log in before you can comment on or make changes to this bug.