Bug 814987 - FTBFS in EL-7 (solved)
FTBFS in EL-7 (solved)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rubygem-test-unit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 17:32 EDT by Matěj Cepl
Modified: 2018-04-11 14:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-22 01:53:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch on .spec file (589 bytes, patch)
2012-04-21 17:32 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2012-04-21 17:32:07 EDT
Created attachment 579225 [details]
suggested patch on .spec file

Description of problem:
spec file has only Fedora conditionals, which don't work on RHEL. see attached patch

Version-Release number of selected component (if applicable):
rubygem-test-unit-2.4.5-2.fc17
Comment 1 Mamoru TASAKA 2012-04-21 22:57:03 EDT
Why do I have to modify spec for RHEL 7, of which I can never know the status of development? RHEL status can only be seen by Redhat people, and I can never know what the correct answer is!!
Comment 2 Mamoru TASAKA 2012-04-21 23:00:22 EDT
A more bit explanation:
So I don't know if the spec file you attached is correct because I don't know the status of RHEL. If you need some fix for RHEL7, it should be done internally on Redhat, not on Fedora.

So basically speaking, if people say "your spec file doesn't work on RHEL", I have to say "I don't know because I don't know RHEL". I only care for Fedora.
Comment 3 Matěj Cepl 2012-04-22 01:53:57 EDT
(In reply to comment #2)
> A more bit explanation:
> So I don't know if the spec file you attached is correct because I don't know
> the status of RHEL. If you need some fix for RHEL7, it should be done
> internally on Redhat, not on Fedora.

OK, I thought that the suggested fix is self-explaining. But if you don't want to apply it, your call.

Note You need to log in before you can comment on or make changes to this bug.