Bug 815079 - Fedora's arduino version number format is slightly different from normal arduino.
Summary: Fedora's arduino version number format is slightly different from normal ardu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arduino
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Peter Oliver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-22 11:57 UTC by zachw
Modified: 2012-05-28 01:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-28 01:21:19 UTC
Type: Bug


Attachments (Terms of Use)

Description zachw 2012-04-22 11:57:42 UTC
Description of problem:
Using the arduino install from yum, the file /usr/share/arduino/lib/version.txt says 0100, but downloaded blob from arduino website says 1.0. Fedora should match the blob.

I noticed when trying to use arduino-cmake, 0100 was interpreted as 0.1 and compiling the example project failed due to wrong include path for pins_arduino.h.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2012-05-04 19:54:29 UTC
arduino-1.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/arduino-1.0-4.fc17

Comment 2 Fedora Update System 2012-05-04 22:17:34 UTC
Package arduino-1.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing arduino-1.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7321/arduino-1.0-4.fc17
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-05-28 01:21:19 UTC
arduino-1.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.