Bug 815094 - Can't boot from hard disk in UEFI after installing RHEL 6.2 x86
Can't boot from hard disk in UEFI after installing RHEL 6.2 x86
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.2
i386 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-22 09:16 EDT by Jack Zhou
Modified: 2012-04-26 17:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 13:17:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Zhou 2012-04-22 09:16:52 EDT
Description of problem:
After installing RHEL 6.2 32-bit to our server IBM System x via NFS, we can't boot from hard disk in UEFI. We select option "Boot from file" in UEFI, and don't find the *.efi bootable file. I find that in RHEL 6.2 64-bit ISO image, there is a EFI directory and the bootable file BOOTX64.efi locate in EFI/BOOT/. But in RHEL 6.2 32-bit ISO image, the EFI directory doesn't exist. Is this means that RHEl 6.2 32-bit doesn't support UEFI mode? How we can boot from hard disk after installing RHEl 6.2 32-bit?

Version-Release number of selected component (if applicable):
Anaconda for RHEL 6.2 32-bit

How reproducible:
Always


Steps to Reproduce:
1. Install RHEL 6.2 32-bit to the machine with UEFI firmware
2. Try to boot into hard disk from UEFI
  
Actual results:
We can't boot into hard disk, and in the "Boot from file" option, the efi bootable file can't be found.

Expected results:
We can boot into hard disk, and in the "Boot from file" option, the efi bootable file can be found.

Additional info:
Comment 2 Jack Zhou 2012-04-23 21:29:30 EDT
Hi, anaconda team,
Can you give us some comments for this issue? We need to fix this issue as soon as possible.
Comment 3 David Cantrell 2012-04-24 13:17:58 EDT
While Red Hat welcomes bug reports on Red Hat products here in our public
bugzilla database, please keep in mind that bugzilla is not a support tool or
means of accessing support.  If you would like technical support please visit
our support portal at access.redhat.com or call us for information on
subscription offerings to suit your needs.
Comment 4 Jack Zhou 2012-04-24 22:11:26 EDT
(In reply to comment #3)
> While Red Hat welcomes bug reports on Red Hat products here in our public
> bugzilla database, please keep in mind that bugzilla is not a support tool or
> means of accessing support.  If you would like technical support please visit
> our support portal at access.redhat.com or call us for information on
> subscription offerings to suit your needs.

As you said, it is not a bug. Just RHEL 6.2 32-bit doesn't support UEFI mode, right?
Comment 5 David Cantrell 2012-04-26 17:09:02 EDT
Correct.

Note You need to log in before you can comment on or make changes to this bug.