Bug 815235 - 500 when using dupe emails in /prefs page
500 when using dupe emails in /prefs page
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.8
Unspecified Unspecified
high Severity high (vote)
: 0.9.0
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 03:44 EDT by Raymond Mancy
Modified: 2014-12-07 20:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:40:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-04-23 03:44:29 EDT
Using a dupe email in the /prefs page will result in a DB error, for the same reasons as in bz 784863.

We need to add proper validation for the email value.
Comment 1 Raymond Mancy 2012-04-23 12:35:34 EDT
On review.
http://gerrit.beaker-project.org/#/c/1028/
Comment 4 Dan Callaghan 2012-06-26 02:40:04 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.