Bug 815250 - Realtek RTS5116 Card Reader does not work Unassigned class [ff00]
Realtek RTS5116 Card Reader does not work Unassigned class [ff00]
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 04:17 EDT by Alexander Lindqvist
Modified: 2012-08-13 17:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 17:27:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Lindqvist 2012-04-23 04:17:08 EDT
Description of problem:
The HP Folio 13 comes with a RTS5116 Memory card reader which does not work on EL6.2

Version-Release number of selected component (if applicable):
2.6.32-220.13.1.el6.x86_64

How reproducible:
Boot computer, insert memory card.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Does not detect memory cards

Expected results:
Should detect memory cards

Additional info:
From lspci:

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
03:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5116 PCI Express Card Reader (rev 01)
09:00.0 USB controller: Fresco Logic Device 1009 (rev 02)
Comment 2 Don Zickus 2012-04-27 09:17:35 EDT
Hi Alexander,

The RTS5116 memory card reader uses the rts_pstor driver from upstream.  However this driver is in the staging area and is not deemed acceptable to merge to fully supported by the upstream maintainer.  Therefore RHEL-6 has no plans to support this card.

We are working with the driver author to improve their driver such that it can be acceptably supported by the upstream community.  Until that happens, I am afraid your card reader will not work in RHEL-6.

Cheers,
Don
Comment 3 RHEL Product and Program Management 2012-05-03 01:36:36 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Don Zickus 2012-08-13 17:27:09 EDT
I don't see any movement upstream in the direction of cleaning up this driver.  I do not anticipate this going into RHEL-6 any time soon.

Closing this out for now.  If anything changes and upstream accepts the new version of this driver, then feel free to re-open.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.