Bug 815269 - Productized Guvnor runs missing 'default' profile instead of 'production' profile by default
Productized Guvnor runs missing 'default' profile instead of 'production' pro...
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ER7
: BRMS 5.3.0.GA
Assigned To: Ryan Zhang
Lukáš Petrovický
:
Depends On: 817618
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 05:01 EDT by Jiri Svitak
Modified: 2015-06-01 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
atangrin: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Jiri Svitak 2012-04-23 05:01:03 EDT
I used to run Guvnor without any profile specification, so I used the default profile. However, since BRMS 5.3.0 ER6 this profile has been removed, but Guvnor still tries to run it. This leads to an exception about missing files from the default profile. I have been told that now is just production profile available. So it would be great to run Guvnor just with
./run.sh
instead of each time typing:
./run.sh -c production
Comment 1 Ryan Zhang 2012-04-23 05:30:38 EDT
It's true.
This will be fixed soon.
Thanks
Comment 2 Ryan Zhang 2012-04-26 10:32:10 EDT
Nick has fixed this issue in build code. So update this issue as modified.
Comment 3 Jiri Svitak 2012-05-02 10:55:58 EDT
Since the default profile will return:
https://bugzilla.redhat.com/show_bug.cgi?id=817618
This bug has no longer any sense. So I think that for developers should command
./run.sh
mean starting of default profile as before.
Comment 4 Ryan Zhang 2012-05-03 03:45:21 EDT
yep, it makes sense to revert the change.

Thanks for reminding here.
Comment 5 Ryan Zhang 2012-05-10 21:59:55 EDT
This is minor issue which is fixed and has no risk to the product. This issue couple with issue https://bugzilla.redhat.com/show_bug.cgi?id=817618 which is a blocker issue
I think it should be included in product too.

This issue should add in block+ and 5.3.0+ flag.
Comment 7 Ryan Zhang 2012-05-14 04:15:54 EDT
The fixed for this issue should be included in ER7. Please do verification on it.
Comment 8 Lukáš Petrovický 2012-05-14 08:14:23 EDT
default profile is run with ER7. VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.