Bug 815304 - Validation required for "-E, --environment" option of aeolus-image list
Validation required for "-E, --environment" option of aeolus-image list
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Maros Zatko
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 06:25 EDT by Aziza Karol
Modified: 2012-12-04 10:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
User can now use -e as an alternative to -E.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:04:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 14:51:45 EST

  None (edit)
Description Aziza Karol 2012-04-23 06:25:05 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
# aeolus-image  list -h
Usage: aeolus-image list [command options]
    -i, --images                     Retrieve a list of images
    -E, --environment ENVIRONMENT    Limit image list to environment


#aeolus-image list --images --e default
ID                                       Name            Environment     OS         OS Version     Arch       Description        
------------------------------------     -----------     -----------     ------     ----------     ------     --------------     
3bb1673e-8d11-11e1-847c-0015c5ef5495     RHEL5-Basic     default         RHEL-5     U7             x86_64     RHEL57 x86_64      

  


Actual results:
Valid Output is displayed with invalid option for environment.The valid option is -E and not -e.

Expected results:
validation required if invalid option is used.

#aeolus-image list --images --e default
Warning, invalid option: -e
	See `aeolus-image list -h` for usage information.


Additional info:
 rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 wes hayutin 2012-04-23 14:52:34 EDT
hrm.. I think that is a python library.. not sure if they'll fix that
Comment 3 Hugh Brock 2012-05-07 14:14:29 EDT
Not clear which flags are which in the description? Can we retest?
Comment 4 Dave Johnson 2012-05-07 14:34:04 EDT
All seems to be working now with the following in rc1... moving to verified

rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch


[root@ibm-x3690x5-01 ~]# aeolus-image list --images -e default
ID                                       Name           Environment     OS     OS Version     Arch     Description     
------------------------------------     ----------     -----------     --     ----------     ----     -----------     
47d33b22-39ef-47c8-a142-d18e85474880     rhev-agent     default                                                        

[root@ibm-x3690x5-01 ~]# aeolus-image list --images --e default
ID                                       Name           Environment     OS     OS Version     Arch     Description     
------------------------------------     ----------     -----------     --     ----------     ----     -----------     
47d33b22-39ef-47c8-a142-d18e85474880     rhev-agent     default                                                        

[root@ibm-x3690x5-01 ~]# aeolus-image list --images -E default
ID                                       Name           Environment     OS     OS Version     Arch     Description     
------------------------------------     ----------     -----------     --     ----------     ----     -----------     
47d33b22-39ef-47c8-a142-d18e85474880     rhev-agent     default                                                        
[root@ibm-x3690x5-01 ~]# aeolus-image list --images --E default
ID                                       Name           Environment     OS     OS Version     Arch     Description     
------------------------------------     ----------     -----------     --     ----------     ----     -----------     
47d33b22-39ef-47c8-a142-d18e85474880     rhev-agent     default                                                        

[root@ibm-x3690x5-01 ~]#
Comment 6 Ronelle Landy 2012-09-20 11:50:14 EDT
The tested output seems to contradict the expected results above in that using either the '-e' or '--e' option returns valid output:

************

Expected results:
validation required if invalid option is used.

#aeolus-image list --images --e default
Warning, invalid option: -e
	See `aeolus-image list -h` for usage information.

*************

However checking with Dave Johnson, it appears that it's ok for '-e' option to work and return valid output (copyng chat comment)

<dajo> yeah, so dev wired in -e support as well

Test output is copied below:

>>  aeolus-image list --images -e default
ID                                       Name                                                 Environment     OS         OS Version     Arch       Description                                           
------------------------------------     ------------------------------------------------     -----------     ------     ----------     ------     -------------------------------------------------     
bb2ef19a-02a3-11e2-a925-e83935c31258     RHEL6-2Basic                                         default         RHEL-6     2              x86_64     RHEL62 x86_64                                         
be900f68-02a3-11e2-a925-e83935c31258     RHEL5-Basic                                          default         RHEL-5     U8             x86_64     RHEL57 x86_64                                         
2b2b708b-fed4-4079-ba5f-59844a40f7f3      ami-31d41658RHELi386                                default                                                                                                    
7ce40939-c6f8-4064-9df7-9f718f30b221      ami-7dea2614RHELx86_64                              default                                                                                                    
ff056c77-60b7-4ee4-8233-22a5b626a217      ami-c31cd8aaFedorax86_64                            default          



>>  aeolus-image list --images --e default
ID                                       Name                                                 Environment     OS         OS Version     Arch       Description                                           
------------------------------------     ------------------------------------------------     -----------     ------     ----------     ------     -------------------------------------------------     
bb2ef19a-02a3-11e2-a925-e83935c31258     RHEL6-2Basic                                         default         RHEL-6     2              x86_64     RHEL62 x86_64                                         
be900f68-02a3-11e2-a925-e83935c31258     RHEL5-Basic                                          default         RHEL-5     U8             x86_64     RHEL57 x86_64                                         
2b2b708b-fed4-4079-ba5f-59844a40f7f3      ami-31d41658RHELi386                                default                                                                                                    
7ce40939-c6f8-4064-9df7-9f718f30b221      ami-7dea2614RHELx86_64                              default                                                                                                    
ff056c77-60b7-4ee4-8233-22a5b626a217      ami-c31cd8aaFedorax86_64                            default                                                                                                        

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
Comment 7 Ronelle Landy 2012-09-20 11:57:45 EDT
As a side note, the '-e' option is *not* listed in the help:


***********

aeolus-image list --help
Usage: aeolus-image list [command options]
    -i, --images                     Retrieve a list of images
    -E, --environment ENVIRONMENT    Limit image list to environment
    -b, --builds ID                  Retrieve the builds of an image
    -t, --targetimages ID            Retrieve the target images from a build
    -P, --providerimages ID          Retrieve the provider images from a target image
    -g, --targets                    Retrieve the values available for the --target parameter
    -p, --providers                  Retrieve the values available for the --provider parameter
    -a, --accounts                   Retrieve the values available for the --account parameter
    -c, --environments               Retrieve the values available for the --environment parameter
    -h, --help                       Get usage information for this command

Examples:
aeolus-image list --images                     # list available images
aeolus-image list --images --environment $env   # list available images for an environment
aeolus-image list --builds $image_id           # list the builds of an image
aeolus-image list --targetimages $build_id     # list the target images from a build
aeolus-image list --providerimages $target_id  # list the provider images from a target image
aeolus-image list --targets                    # list the values available for the --target parameter
aeolus-image list --providers                  # list the values available for the --provider parameter
aeolus-image list --accounts                   # list the values available for the --account parameter

N.B. Aeolus Credentials should be defined in the configuration file ~/.aeolus-cli
Comment 9 errata-xmlrpc 2012-12-04 10:04:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.