This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 815402 - ami-cef922a7, ami-eaff2483: menu.lst not a symlink
ami-cef922a7, ami-eaff2483: menu.lst not a symlink
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.3
Assigned To: Jay Greguske
mkovacik
: EC2
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 10:30 EDT by mkovacik
Modified: 2012-06-20 11:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:10:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mkovacik 2012-04-23 10:30:46 EDT
Description of problem:
The file "/boot/grub/menu.lst" isn't a symlink of "/boot/grub/grub.conf"

Version-Release number of selected component (if applicable):
ami-cef922a7, ami-eaff2483

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
/boot/grub/menu.lst isn't a symlink pointing to /boot/grub/grub.conf 

Expected results:
/boot/grub/menu.lst is a symlink of /boot/grub/grub.conf 

Additional info:
### Screen Log in 6.2
[root@ip-10-194-147-74 ~]#  file /boot/grub/menu.lst
boot/grub/menu.lst: symbolic link to `grub.conf'

### Screen Log in 6.3
[root@ip-10-76-159-206 ~]# file /boot/grub/menu.lst 
/boot/grub/menu.lst: ASCII text
Comment 1 mkovacik 2012-05-11 11:49:49 EDT
Latest amis suffering, see: bug 820558 and bug 820549.
Comment 3 Jay Greguske 2012-05-13 10:38:20 EDT
Adding Kevin Wright to the CC. Kevin can you look into this?
Comment 4 RHEL Product and Program Management 2012-05-17 00:03:50 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Jay Greguske 2012-05-17 09:01:08 EDT
This has to get fixed for 6.3 EC2-images. If it doesn't, kernel updates will not properly boot.
Comment 7 Alexander Todorov 2012-05-23 08:47:10 EDT
# file /boot/grub/menu.lst 
/boot/grub/menu.lst: symbolic link to `grub.conf'

This is with the 0522.n.0 images.
Comment 8 errata-xmlrpc 2012-06-20 11:10:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0971.html

Note You need to log in before you can comment on or make changes to this bug.