Bug 815424 - After upgrade to ypbind-1.3.5-1.fc16.x86_64 the NIS logins do not function anymore without restart of service
After upgrade to ypbind-1.3.5-1.fc16.x86_64 the NIS logins do not function an...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 11:19 EDT by eyurtese
Modified: 2012-04-28 11:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 11:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eyurtese 2012-04-23 11:19:28 EDT
Description of problem:

yum.log
Apr 23 11:58:15 Updated: 3:ypbind-1.35-1.fc16.x86_64
Version-Release number of selected component (if applicable):
http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078246.html

How reproducible:

The machine uses DHCP to get IP, and uses NIS for authentication. This used to work until I updated the packages. (last update was done on March 24).

Steps to Reproduce:
1. Make a fedora installation which uses DHCP + NIS
2. Update to latest ypbind
3.
  
Actual results:
logins are unavailable until restart of ypbind.service

Expected results:
I would expect to be able to login.

Additional info:
I guess the DHCP can be the culprit here? ypbind should start after DHCP becomes ready...?
Comment 1 Honza Horak 2012-04-24 10:39:25 EDT
Thanks for the report. I believe, this is a the same issue as in bug #812501. A fixed build is already in updates-testing, feel free to test the build:

Package ypbind-1.35-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ypbind-1.35-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6135/ypbind-1.35-2.fc17
then log in and leave karma (feedback).
Comment 2 eyurtese 2012-04-28 11:21:54 EDT
It does not work, I am using FC16 are you sure I should be able to download this package???:

# su -c 'yum update --enablerepo=updates-testing ypbind-1.35-2.fc17'
Loaded plugins: langpacks, presto, refresh-packagekit
updates-testing/metalink                                                                                                                               |  23 kB     00:00     
updates-testing                                                                                                                                        | 4.5 kB     00:00     
updates-testing/primary_db                                                                                                                             | 1.0 MB     00:00     
updates-testing/group_gz                                                                                                                               | 435 kB     00:00     
No Match for argument: ypbind-1.35-2.fc17
No package ypbind-1.35-2.fc17 available.
No Packages marked for Update
#


Also, I already have 1.35-2 version of this package:


# rpm -qa |grep ypbind
ypbind-1.35-2.fc16.x86_64
#


Are you sure this is the same problem?
Comment 3 eyurtese 2012-04-28 11:25:16 EDT
Oh sorry, I just realized I updated the machine and got the package right moments ago and after reboot everything was working as expected:

Updated:
  NetworkManager.x86_64 1:0.9.4-3.git20120403.fc16        NetworkManager-glib.x86_64 1:0.9.4-3.git20120403.fc16    NetworkManager-gnome.x86_64 1:0.9.4-3.git20120403.fc16   
  NetworkManager-gtk.x86_64 1:0.9.4-3.git20120403.fc16    evolution.x86_64 0:3.2.3-3.fc16                          evolution-NetworkManager.x86_64 0:3.2.3-3.fc16           
  firefox.x86_64 0:12.0-1.fc16                            flac.x86_64 0:1.2.1-8.fc16                               gnome-color-manager.x86_64 0:3.2.3-2.fc16                
  ibus-hangul.x86_64 0:1.4.1-1.fc16                       im-chooser.x86_64 0:1.5.2.2-1.fc16                       im-chooser-common.x86_64 0:1.5.2.2-1.fc16                
  libmtp.x86_64 0:1.1.3-2.fc16                            mdadm.x86_64 0:3.2.3-7.fc16                              openssl.x86_64 0:1.0.0i-1.fc16                           
  pixman.x86_64 0:0.24.4-1.fc16                           systemd.x86_64 0:37-19.fc16                              systemd-sysv.x86_64 0:37-19.fc16                         
  systemd-units.x86_64 0:37-19.fc16                       xulrunner.x86_64 0:12.0-1.fc16                           ypbind.x86_64 3:1.35-2.fc16     

Now everything works. Thanks for your time.

Note You need to log in before you can comment on or make changes to this bug.