This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 815443 - Fix typo in newly introduced API SearchMapping#getFullTextFilerDefs
Fix typo in newly introduced API SearchMapping#getFullTextFilerDefs
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: HibernateSearch (Show other bugs)
2.0.0.ER3
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0.0.ER5
Assigned To: Strong Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 11:52 EDT by Emmanuel Bernard
Modified: 2013-12-02 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously there was a type error in the programmatic API 'getFullTextFilerDefs' which should have been "getFullTextFilterDefs". This has been fixed with JBoss Web Framework Kit 2 and 'getFullTextFilterDefs' should be used from now on.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 05:12:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Bernard 2012-04-23 11:52:46 EDT
SearchMapping#getFullTextFilerDefs => SearchMapping#getFullTextFilterDefs

See https://hibernate.onjira.com/browse/HSEARCH-1094
Comment 1 Emmanuel Bernard 2012-04-23 11:53:56 EDT
Will be fixed asap in the community by Emmanuel or Sanne and can then be cherry picked to the product branch
Comment 2 Emmanuel Bernard 2012-04-24 08:29:19 EDT
This issue has been fixed in the community project (master).
Comment 3 Karel Piwko 2012-05-11 07:05:27 EDT
Verified in WFK 2.0.0.ER5.
Comment 4 Emmanuel Bernard 2012-05-14 11:04:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When using the programmatic mapping API, `getFullTextFilerDefs` will be renamed `getFullTextFilterDefs` to fix the typo. 
Since it's a fairly new API, we don't expect many customers to have to adjust.
Comment 8 Rebecca Newton 2012-06-19 02:16:41 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1 @@
-When using the programmatic mapping API, `getFullTextFilerDefs` will be renamed `getFullTextFilterDefs` to fix the typo. 
+Previously there was a type error in the programmatic API 'getFullTextFilerDefs' which should have been "getFullTextFilterDefs". This has been fixed with JBoss Web Framework Kit 2 and 'getFullTextFilterDefs' should be used from now on.-Since it's a fairly new API, we don't expect many customers to have to adjust.
Comment 9 Karel Piwko 2012-06-22 05:12:01 EDT
Fix is delivered in WFK 2.0.0.

Note You need to log in before you can comment on or make changes to this bug.