Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 81545 - libelf.la missing
libelf.la missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libtool (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-10 04:45 EST by Need Real Name
Modified: 2015-01-07 19:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 09:10:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing libelf.la (883 bytes, text/plain)
2003-09-22 15:49 EDT, Rok Papez
no flags Details

  None (edit)
Description Need Real Name 2003-01-10 04:45:45 EST
Description of problem:
I was trying to build php4.3.0 rpm based on the php4.2 rpm but new source.  
Link failed linking to libelf (which is installed); strace shows it to be 
looking for libelf.la; I notice other lib* packages include .la files for 
libraries so I guess libelf should also include the .la version to help libtool 
linking, though I really think libtool should have been able to manage without 
it so perhaps it is a libtool bug?


Version-Release number of selected component (if applicable):
0.8.2

How reproducible:
very

Steps to Reproduce:
1.ls -l /usr/lib/libelf.la
2.note nothing there
3.????
4.profit!
    
Additional info:
Maybe libtool is at error?  The system is RH8.0 fully up2date
Comment 1 Jakub Jelinek 2003-01-13 06:45:30 EST
libtool ought to work even if there is no .la file (in this case primarily because
libelf (nor elfutils) are libtoolized).
If is either libtool bug, or bug in the php source you're trying to build.
Comment 2 Joe Orton 2003-01-21 09:10:00 EST
I've seen similar problems with PHP, I think it was because libnetsnmp.la had a
depedency on libelf.la, or something like that - try grabbing a more recent set
of net-snmp packages.
Comment 3 Rok Papez 2003-09-22 15:49:03 EDT
Created attachment 94638 [details]
Missing libelf.la

A dummy libelf.la
Comment 4 Rok Papez 2003-09-22 15:52:23 EDT
Comment on attachment 94638 [details]
Missing libelf.la

Context: RPMS build

Add this dummy libelf.la to SOURCES. Then in %prep section do:
cp -a %{SOURCExy} .
LD_LIBRARY_PATH=`pwd` make <...>

Note You need to log in before you can comment on or make changes to this bug.