Bug 815475 - remote-viewer segfaults when starting Spice vdagent after migration.
remote-viewer segfaults when starting Spice vdagent after migration.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 12:48 EDT by Marian Krcmarik
Modified: 2012-08-30 08:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 08:17:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-04-23 12:48:31 EDT
Description of problem:
remote-viewer seqfaults when starting Spice vdagent after migration.
backtrace:
#0  IA__gdk_x11_window_get_drawable_impl (window=0x0) at gdkdrawable-x11.c:961
#1  0x00007f5ecaedb41c in try_mouse_ungrab (display=0xcaf380 [SpiceDisplay])
    at spice-widget.c:740
#2  0x00007f5ecaedd260 in update_mouse_mode (channel=0xc8f0e0 [SpiceMainChannel], data=
    0xcaf380) at spice-widget.c:1532
#3  0x0000003bc0e0bb3e in IA__g_closure_invoke (closure=0x17165b0, return_value=0x0, 
    n_param_values=1, param_values=0xc13e00, invocation_hint=0x7fff82c503f0)
    at gclosure.c:767
#4  0x0000003bc0e20e23 in signal_emit_unlocked_R (node=<value optimized out>, detail=0, 
    instance=0xc8f0e0, emission_return=0x0, instance_and_params=0xc13e00)
    at gsignal.c:3247
#5  0x0000003bc0e220af in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, var_args=
    0x7fff82c505e0) at gsignal.c:2980
#6  0x0000003bc0e225f3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:3037
#7  0x00007f5ecabf3991 in emit_main_context (opaque=<value optimized out>)
    at gio-coroutine.c:199
#8  0x0000003bc0a38f0e in g_main_dispatch (context=0xa9b8a0) at gmain.c:1960
#9  IA__g_main_context_dispatch (context=0xa9b8a0) at gmain.c:2513
#10 0x0000003bc0a3c938 in g_main_context_iterate (context=0xa9b8a0, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2591
#11 0x0000003bc0a3cd55 in IA__g_main_loop_run (loop=0xbda4e0) at gmain.c:2799
#12 0x000000341b74c307 in IA__gtk_main () at gtkmain.c:1218
#13 0x000000000041bf55 in main (argc=1, argv=0x7fff82c50b88) at remote-viewer-main.c:178
Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect to a guest with remote-viewer client.
2. Make sure Spice vdagent service is turned off on guest.
3. Migrate guest.
4. Start spice vdagent service
  
Actual results:
Segfault of remote-viewer

Expected results:
No segfaults

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 01:40:05 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Marc-Andre Lureau 2012-08-30 05:28:27 EDT
Tested today with remote-viewer 0.5.2-9 and spice-gtk-0.11.11 on rhel 6.3, connected to qemu master with XP guest, starting agent after migration with success (semi-seamless migration).

Marian, can you still reproduce it? can you give further details? thanks
Comment 4 Marian Krcmarik 2012-08-30 08:17:11 EDT
(In reply to comment #3)
> Tested today with remote-viewer 0.5.2-9 and spice-gtk-0.11.11 on rhel 6.3,
> connected to qemu master with XP guest, starting agent after migration with
> success (semi-seamless migration).
> 
> Marian, can you still reproduce it? can you give further details? thanks

I can reproduce on virt-viewer-0.5.2-6.el6 but *not* able to reproduce on 0.5.2-9 and that's why I am closing as CURRENTRELEASE since this version was already shipped.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.