Bug 815496 - FTBFS: perl-AnyEvent
FTBFS: perl-AnyEvent
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-AnyEvent (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On: 816131
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 14:04 EDT by Marcela Mašláňová
Modified: 2012-04-26 14:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-AnyEvent-7.0-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 14:01:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2012-04-23 14:04:03 EDT
Could you please fix this issue? Even kde-plasma-networkmanagement can't be rebuilt now.
On x86_64:
        perl-AnyEvent-6.14-1.fc18.x86_64 requires perl(IO::Async::Loop) >= 0:0.33
        perl-AnyEvent-6.14-1.fc18.x86_64 requires perl(FLTK) >= 0:0.532
        perl-AnyEvent-6.14-1.fc18.x86_64 requires perl(Cocoa::EventLoop)

fyi there is already new version of AnyEvent-7.0. It has the same missing requirements.

I suggest using http://ppisar.fedorapeople.org/betterfedora/resolvedeps-f16 before pushing package into Fedora. You need to change repoid to rawhide.
Comment 1 Marcela Mašláňová 2012-04-23 14:13:11 EDT
We need to package:
http://search.cpan.org/~typester/Cocoa-EventLoop-0.04/
http://search.cpan.org/~sanko/FLTK-0.532009/lib/FLTK.pm (not sure which version)
http://search.cpan.org/~pevans/IO-Async-0.47/

I'll try to package something of it and it as dependency of this bug.
Comment 2 Nicolas Chauvet (kwizart) 2012-04-23 14:29:22 EDT
perl-IO-ASync 0.47 update(already packaged) needs:
  requires:
    !  CPS is not installed
  build_requires:
    !  Test::Identity is not installed

But usually perl-AnyEvent doesn't need much dependency, it should only be a matter of filtering as advertised in the package.
Sorry for the mess and thx for your report.
Comment 3 Marcela Mašláňová 2012-04-25 05:29:46 EDT
It looks like KDE people fixed their problem, at least I don't see any bugs.

Cocoa::Event is used only on Mac if I understand definition assertos 'MacOSX'; correctly. So we need only filter the requirement on this one.

FLTK depends on experimental Alien::FLTK:
http://search.cpan.org/~sanko/Alien-FLTK2-0.09204/lib/Alien/FLTK2.pm
Hm, I would put FLTK in sub-package of AnyEvent. This would be great candidate for soft dependency if we have that possibility in rpm.

I'll look at the last dependency.
Comment 4 Nicolas Chauvet (kwizart) 2012-04-25 06:02:57 EDT
(In reply to comment #3)
..
> for soft dependency if we have that possibility in rpm.

Hi Marcela,
I think the problem was solved (by filtering).

Now I really think the comment while building perl-AnyEvent is pretty clear.
This package do not have any dependency. It will select an event loop depending on what is available on the system and fall-back on an internal one if none is usable.

Crumble the package will lead nowhere. This is not the purpose of RPM to deicide the appropriate event loop implementation of a undetermined system. Instead, AnyEvent users want to only rely on this package exactly for that reason, it will select the an appropriate event loop with only one dependency cost.
Comment 5 Marcela Mašláňová 2012-04-25 06:32:00 EDT
Reviews are prepared #816131
Comment 6 Paul Howarth 2012-04-26 14:01:50 EDT
perl-AnyEvent-7.0-1.fc18 has no dependency issues (I installed it successfully on a Rawhide VM) so I consider this issue fixed.

Updated/new versions of IO::Async, FLTK etc. could be added as build requirements at a later date for extra testing, but they're not actually required dependencies of this package.

Note You need to log in before you can comment on or make changes to this bug.