Bug 815553 - Using the Beta x86_64 DVD to upgrade a F16 system to F17 (on a btrfs) leaves a 00_header.rpmsave file in /etc/grub.d/
Using the Beta x86_64 DVD to upgrade a F16 system to F17 (on a btrfs) leaves ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 16:22 EDT by Peter Trenholme
Modified: 2012-04-30 19:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 19:09:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2012-04-23 16:22:24 EDT
Description of problem:
The problem is that the grub2-mkconfig script attempts to source that file in addition to the new 00_header file. This causes the grug2-prober script to abort the generation of the new boot script.

Version-Release number of selected component (if applicable):


How reproducible: I only tried it once.


Steps to Reproduce: Run the DVD to update a F16 installation (on a btrfs, but I don't think that's relevant).
1.
2.
3.
  
Actual results: grub2-mkconfig aborts (causing anaconda to report that the new system "may not be bootable").


Expected results: Successful run of grub2-mkconfig


Additional info: Renaming 00_header.rpmsave to 00_header~ fixed the problem. I'd suggest that the rpm package be altered to not create (or rename) 00_header.rpmsave, or the grub2-mkconfig script be alters to it doesn't try to source the .rpmsave file.
Comment 1 Peter Trenholme 2012-04-23 16:26:11 EDT
Typo correction:

I'd suggest that the rpm package be altered to not create (or rename)
00_header.rpmsave, or the grub2-mkconfig script be altered so it doesn't try to
source the .rpmsave file.
Comment 2 Mads Kiilerich 2012-04-23 16:37:51 EDT
The files are considered configuration files and should thus be backed up.

Filtering has been fixed upstream in http://bzr.savannah.gnu.org/lh/grub/trunk/grub/revision/4228 and will be included in the 2.0beta4 package coming soon.
Comment 3 Mads Kiilerich 2012-04-30 19:09:41 EDT
grub2-2.0-0.24.beta4.fc17 has been pushed to f17 stable - closing.

Note You need to log in before you can comment on or make changes to this bug.