Bug 815557 - Installer throwing "Could not allocate requested partitions: not enough space for LVM requests"
Installer throwing "Could not allocate requested partitions: not enough space...
Status: CLOSED DUPLICATE of bug 744129
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Vratislav Podzimek
Release Test Team
:
: 814727 (view as bug list)
Depends On:
Blocks: 711169
  Show dependency treegraph
 
Reported: 2012-04-23 16:44 EDT by apfeiffe
Modified: 2015-09-16 19:47 EDT (History)
23 users (show)

See Also:
Fixed In Version: anaconda-13.21.172-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 23:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
consolelog1 (315.77 KB, image/jpeg)
2012-04-23 16:53 EDT, apfeiffe
no flags Details
zip file containing screen shots of the error (817.01 KB, application/x-zip-compressed)
2012-04-23 16:54 EDT, apfeiffe
no flags Details
console output showing it formatting the lun when LVM isn't in use (166.24 KB, image/pjpeg)
2012-04-23 18:06 EDT, apfeiffe
no flags Details
anaconda.log (7.04 KB, text/plain)
2012-04-23 19:05 EDT, apfeiffe
no flags Details
program.log (56.54 KB, text/plain)
2012-04-23 19:05 EDT, apfeiffe
no flags Details
storage.log (251.74 KB, text/plain)
2012-04-23 19:06 EDT, apfeiffe
no flags Details
anaconda.log.config2 (7.71 KB, text/plain)
2012-04-24 10:51 EDT, apfeiffe
no flags Details
program.log.config2 (86.35 KB, text/plain)
2012-04-24 10:52 EDT, apfeiffe
no flags Details
storage.log.config2 (430.53 KB, text/plain)
2012-04-24 10:52 EDT, apfeiffe
no flags Details
screen shot (60.49 KB, image/png)
2012-04-25 22:49 EDT, IBM Bug Proxy
no flags Details
tar ball of logs in /tmp of installer (3.29 MB, application/x-tar)
2012-04-25 22:49 EDT, IBM Bug Proxy
no flags Details
anaconda.log (9.11 KB, application/octet-stream)
2012-04-25 22:49 EDT, IBM Bug Proxy
no flags Details
Screenshot of Paritioner where 63GB swap partition was allocated on 64GB RAM system (68.80 KB, image/png)
2012-04-25 22:49 EDT, IBM Bug Proxy
no flags Details
Screenshot of Paritioner where 131GB swap partition was allocated on 256GB RAM system (74.97 KB, image/png)
2012-04-25 22:50 EDT, IBM Bug Proxy
no flags Details
Screenshot of Paritioner where fails to create lvm when HDD is 70GB & RAM is 256GB (85.30 KB, image/png)
2012-04-25 22:50 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description apfeiffe 2012-04-23 16:44:48 EDT
Description of problem:
I am installing a boot over san install of Red Hat 6.3 Beta 1 to an HP P9500 array .  At the screen which says, "Which type of installation would  you like?" I choose "Use All Space" and throws an error which says:

"Could not allocate requested partitions: not enough space for LVM requests"

If I use this same disk and partition it manually not using LVM, it will work without any issues.

Version-Release number of selected component (if applicable):
- Red Hat 6.3 beta 1 x64
- DL580 G7
- HP P9500  - Main firmware 70-03-04

How reproducible:
Install to a BOS lun on a P9500 array and choose the default partitioning scheme.

Steps to Reproduce:
1. Configure the system with a BOS lun
2. Install Red Hat 6.3 x64 and choose to use all the free space on the disk

Actual results:
Throws an error:
"Could not allocate requested partitions: not enough space for LVM requests"


Expected results:
It should create the LVM devices correctly.

Additional info:
Comment 2 apfeiffe 2012-04-23 16:53:12 EDT
Created attachment 579689 [details]
consolelog1
Comment 3 apfeiffe 2012-04-23 16:54:38 EDT
Created attachment 579691 [details]
zip file containing screen shots of the error
Comment 4 apfeiffe 2012-04-23 18:06:56 EDT
Created attachment 579706 [details]
console output showing it formatting the lun when LVM isn't in use
Comment 5 David Lehman 2012-04-23 18:27:44 EDT
Please attach the following log files, one at a time, to this bug report:

 /tmp/anaconda.log
 /tmp/storage.log
 /tmp/program.log

These logs can obtained by switching to the shell on vt2 (ctrl+alt+f2) and then transferring them to another machine using scp.

Thanks.
Comment 6 apfeiffe 2012-04-23 19:05:32 EDT
Created attachment 579714 [details]
anaconda.log
Comment 7 apfeiffe 2012-04-23 19:05:58 EDT
Created attachment 579715 [details]
program.log
Comment 8 apfeiffe 2012-04-23 19:06:30 EDT
Created attachment 579716 [details]
storage.log
Comment 11 RHEL Product and Program Management 2012-04-24 09:30:45 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 12 apfeiffe 2012-04-24 10:50:25 EDT
I have now hit this on a 2nd configuration.  While reading my server configuration sheet, I realized that I had listed the wrong storage for the original configuration.  Here is the correct listing of components for each configuration and the corresponding log files (sorry for the confusion) 

Configuration 1:
- Server name: HB133248
- Red Hat 6.3 beta 1 x64
- DL580 G7
- 3PAR P10000 - Firmware 3.1.1 MU1
- Log files: 
consolelog1, anaconda.log, program.log, storage.log, console output showing it formatting the lun when LVM isn't in use, zip file containing screen shots of the error


Configuration 2:
- Server Name: HB133249
- Red Hat 6.3 beta 1 x64
- DL585 G7
- HP P9500  - Main firmware 70-03-04
- Log files: anaconda.log.config2, program.log.config2, storage.log.config2
Comment 13 apfeiffe 2012-04-24 10:51:51 EDT
Created attachment 579882 [details]
anaconda.log.config2
Comment 14 apfeiffe 2012-04-24 10:52:16 EDT
Created attachment 579883 [details]
program.log.config2
Comment 15 apfeiffe 2012-04-24 10:52:46 EDT
Created attachment 579884 [details]
storage.log.config2
Comment 16 apfeiffe 2012-04-24 10:54:45 EDT
Adding HP contacts to the defect.
Comment 17 David Lehman 2012-04-25 22:33:48 EDT
*** Bug 814727 has been marked as a duplicate of this bug. ***
Comment 18 IBM Bug Proxy 2012-04-25 22:49:25 EDT
Created attachment 580335 [details]
screen shot
Comment 19 IBM Bug Proxy 2012-04-25 22:49:38 EDT
Created attachment 580336 [details]
tar ball of  logs in /tmp of installer
Comment 20 IBM Bug Proxy 2012-04-25 22:49:47 EDT
Created attachment 580337 [details]
anaconda.log
Comment 21 IBM Bug Proxy 2012-04-25 22:49:57 EDT
Created attachment 580338 [details]
Screenshot of Paritioner where 63GB swap partition was allocated on 64GB RAM system
Comment 22 IBM Bug Proxy 2012-04-25 22:50:07 EDT
Created attachment 580339 [details]
Screenshot of Paritioner where 131GB swap partition was allocated on 256GB RAM system
Comment 23 IBM Bug Proxy 2012-04-25 22:50:19 EDT
Created attachment 580340 [details]
Screenshot of Paritioner where fails to create lvm when HDD is 70GB & RAM is 256GB
Comment 25 apfeiffe 2012-05-02 18:38:02 EDT
I have reproduced this error with snapshot 1.  Will this issue be fixed in Red Hat 6.3 and, if so, do you know what snapshot will have the fix?

Thanks
Comment 26 Vratislav Podzimek 2012-05-03 09:01:37 EDT
(In reply to comment #25)
> I have reproduced this error with snapshot 1.  Will this issue be fixed in Red
> Hat 6.3 and, if so, do you know what snapshot will have the fix?
> 
> Thanks
The error message appears because the current code tries to create a swap with the same size as the amount of RAM with intention to allow hibernation. This might be a problem on some machines, but on the other hand is an expected behaviour e.g. on laptops. The discusion on how to resolve this issue is running and was not finished yet. Simple workaround is to use custom partitioning in such cases.
Comment 27 David Cantrell 2012-05-08 23:00:07 EDT

*** This bug has been marked as a duplicate of bug 744129 ***
Comment 28 IBM Bug Proxy 2012-05-10 01:43:51 EDT
------- Comment From naveedaus@in.ibm.com 2012-05-10 05:38 EDT-------
hello,

please provide us access to
https://bugzilla.redhat.com/show_bug.cgi?id=744129

Thanks,
Naveed
Comment 29 IBM Bug Proxy 2012-05-10 10:31:27 EDT
We're still unable to view 744129. Could you add bugproxy@us.ibm.com to the cc: of that bug please?

Note You need to log in before you can comment on or make changes to this bug.