Bug 815626 - Installation of WinXP guest is slow with big vmem(16G)
Installation of WinXP guest is slow with big vmem(16G)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Amit Shah
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 02:01 EDT by Golita Yue
Modified: 2013-01-09 19:54 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 08:55:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest screen dump (18.62 KB, image/jpeg)
2012-04-24 02:06 EDT, Golita Yue
no flags Details
kvm_stat info (2.75 MB, text/plain)
2012-04-26 01:58 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2012-04-24 02:01:48 EDT
Description of problem:
Installation is very slow for winXP guest with big mem(16G).

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.278.el6.x86_64
kernel 2.6.32-262.el6.x86_64

How reproducible:
1/15

Steps to Reproduce:
1.install a winXP guest with big mem 16G
2.the installation is very slow, cost 60 mins, it is still installing.
  
Actual results:
Installation is very slow for winXP guest with big mem 16G, it is still installing after 60 mins.

Expected results:
should more quickly, within 60 mins.

Additional info:
cmd:
qemu-kvm -drive file=winXP-32.qcow2,index=0,if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2,aio=threads -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device rtl8139,netdev=idB9c6UU,mac=9a:d1:29:ec:ff:27,id=ndev00idB9c6UU,bus=pci.0,addr=0x3 -netdev tap,id=idB9c6UU,fd=26 -m 16384 -smp 8,cores=4,threads=1,sockets=2-cpu 'Opteron_G3' -drive file='ISO/WinXP/32/en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso',index=1,if=none,id=drive-ide0-0-1,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -drive file='isos/windows/winutils.iso',index=2,if=none,id=drive-ide0-1-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file='virtio-win.iso',index=3,if=none,id=drive-ide0-1-1,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-1,id=ide0-1-1 -fda 'kvm/images/winXP-32/answer.vfd' -device usb-tablet,id=usb-tablet1,bus=usb1.0 -spice port=8000,disable-ticketing -vga qxl -rtc base=localtime,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=d,menu=off   -enable-kvm

host info:
processor	: 11
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 8
model name	: Six-Core AMD Opteron(tm) Processor 2427
stepping	: 0
cpu MHz		: 800.000
cache size	: 512 KB
physical id	: 1
siblings	: 6
core id		: 5
cpu cores	: 6
apicid		: 13
initial apicid	: 13
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt npt lbrv svm_lock nrip_save pausefilter
bogomips	: 4399.63
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

# free -m
             total       used       free     shared    buffers     cached
Mem:         32105       4947      27157          0         19        748
-/+ buffers/cache:       4179      27925
Swap:        32767          0      32767


Hit this bug again in qemu-kvm-0.12.1.2-2.282.el6

Tested with small vmem(4G) 50 times, cannot reproduce this bug.
Comment 1 Golita Yue 2012-04-24 02:06:17 EDT
Created attachment 579760 [details]
guest screen dump

The attachment picture is the installation progress status after 60 mins.
Comment 3 Dor Laor 2012-04-25 09:11:06 EDT
We'll probably need some perf tracing/kvm_stat while the slow install happens.
Comment 4 Golita Yue 2012-04-26 01:58:06 EDT
Created attachment 580360 [details]
kvm_stat info
Comment 5 Amit Shah 2012-04-26 05:15:17 EDT
Is this a regression?  Can you try different qemu and host kernel builds?  (Checking RHEL6.2 host would be a good idea too)
Comment 6 Golita Yue 2012-04-26 05:25:37 EDT
(In reply to comment #5)
> Is this a regression?  Can you try different qemu and host kernel builds? 
> (Checking RHEL6.2 host would be a good idea too)

I will create job with RHEL6.2 host to check this problem. will update the test result after the job complete.
Comment 7 Golita Yue 2012-04-27 02:44:06 EDT
Can reproduced with: 
kernel-2.6.32-220.el6.x86_64 
qemu-kvm-0.12.1.2-2.209.el6.x86_64
so this is not a regression.
Comment 8 Ademar Reis 2012-04-30 13:42:42 EDT
Not a regression, not reported by customer, so we'll have to live with it a bit more, since it's too late for RHEL6.3
Comment 9 yunpingzheng 2012-05-14 03:43:51 EDT
repeat in 
kernel-2.6.32-268.el6.x86_64
qemu-kvm-0.12.1.2-2.290.el6.x86_64

when i install winxp using vmem 2G in amd machine. longer then 2hours.
it seems that hang in register components.


host info
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) Dual Core Processor 5400B
stepping	: 2
cpu MHz		: 2800.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips	: 5611.39
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

[root@amd-5400b-4-4 ~]# free -m
             total       used       free     shared    buffers     cached
Mem:          3766       3654        111          0          1       1256
-/+ buffers/cache:       2396       1369
Swap:        32767          1      32766
Comment 10 yunpingzheng 2012-05-14 03:46:28 EDT
during install winxp, in the host tty output :

Message from syslogd@amd-5400b-4-4 at May 14 15:39:03 ...
 kernel:]n+0x30/0xe/0x1ioctl0x71/0x [kvm]

Message from syslogd@amd-5400b-4-4 at May 14 15:39:35 ...
 kernel:]_entit2/0xa080

Message from syslogd@amd-5400b-4-4 at May 14 15:41:36 ...
 kernel:] ? x1d/0x1 [kvm]

Message from syslogd@amd-5400b-4-4 at May 14 15:41:38 ...
 kernel: [69dto_/0x [k<4>[<fffffa0856_to0x1[kv4> fff5d3fn_0/0<ffc8e_pa0x190 [kvm]

Message from syslogd@amd-5400b-4-4 at May 14 15:41:46 ...
 kernel:]_entity+0x2/0xa0

Message from syslogd@amd-5400b-4-4 at May 14 15:42:06 ...
 kernel:]_entit2/0xa0
Comment 11 Amit Shah 2012-05-14 03:59:00 EDT
In the original description, it is mentioned that with small vmem (4G), this does not reproduce.  Has that changed now?

Also, this is only AMD host-specific, right?  Doesn't reproduce on Intel hosts?

The message in comment 10 looks like a kernel panic on the host, but it is incomplete.  Can you get the full message and paste it here?

Also, please try this on AMD host with npt disabled.
Comment 12 yunpingzheng 2012-05-14 04:17:40 EDT
during install the winxp output the follow message:
 kernel:]_entity+02/0xa0

Message from syslogd@amd-5400b-4-4 at May 14 16:11:32 ...
 kernel:] ? tsc_offset+0xab19>] ? printk+0x4esched+0x2a/0x40

Message from syslogd@amd-5400b-4-4 at May 14 16:11:47 ...
 kernel:] ? threadfffffa04e921c>] ? svm_adjust_tsc_offset+0xac/0xc0 [kvm_amd]

Message from syslogd@amd-5400b-4-4 at May 14 16:13:18 ...
 kernel:] tity

Message from syslogd@amd-5400b-4-4 at May 14 16:14:39 ...
 kernel:] ? __dequeue_entity+0x30/0x50
Comment 13 yunpingzheng 2012-05-14 04:21:41 EDT
(In reply to comment #11)
> In the original description, it is mentioned that with small vmem (4G), this
> does not reproduce.  Has that changed now?
> Also, this is only AMD host-specific, right?  Doesn't reproduce on Intel hosts?
yes only in amd host.never reproduce on intel hosts.

> The message in comment 10 looks like a kernel panic on the host, but it is
> incomplete.  Can you get the full message and paste it here?

 
WARNING: at arch/x86/kvm/svm.c:729 svm_adjust_tsc_offset+0xac/0xc0 [kvm_amd]() (Tainted: G        W  ---------------   )
Hardware name: OptiPlex 740 Enhanced
Modules linked in: vfat fat nfs lockd fscache nfs_acl auth_rpcgss vhost_net macvtap macvlan tun kvm_amd kvm sunrpc cpufreq_ondemand powernow_k8 freq_table mperf bridge stp llc ipv6 ppdev parport_pc parport microcode dcdbas serio_raw k8temp edac_core edac_mce_amd snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc sg i2c_nforce2 tg3 ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom pata_acpi ata_generic sata_nv nouveau ttm drm_kms_helper drm i2c_core mxm_wmi video output wmi dm_mirror dm_region_hash dm_log dm_mod [last unloaded: scsi_wait_scan]
Pid: 32622, comm: qemu Tainted: G        W  ---------------    2.6.32-268.el6.x86_64 #1
Call Trace:
 [<ffffffff8106b6b7>] ? warn_slowpath_common+0x87/0xc0
 [<ffffffff8106b70a>] ? warn_slowpath_null+0x1a/0x20
 [<ffffffffa04e921c>] ? svm_adjust_tsc_offset+0xac/0xc0 [kvm_amd]
 [<ffffffffa049182b>] ? kvm_arch_vcpu_load+0xdb/0x140 [kvm]
 [<ffffffffa0487e35>] ? vcpu_load+0x55/0x80 [kvm]
 [<ffffffffa0491ae5>] ? kvm_arch_destroy_vm+0x65/0x170 [kvm]
 [<ffffffffa0486874>] ? kvm_put_kvm+0xe4/0x110 [kvm]
 [<ffffffffa0487948>] ? kvm_vcpu_release+0x18/0x20 [kvm]
 [<ffffffff8117d065>] ? __fput+0xf5/0x210
 [<ffffffff8117d1a5>] ? fput+0x25/0x30
 [<ffffffff81178bcd>] ? filp_close+0x5d/0x90
 [<ffffffff8106e32f>] ? put_files_struct+0x7f/0xf0
 [<ffffffff8106e3f3>] ? exit_files+0x53/0x70
 [<ffffffff8107046d>] ? do_exit+0x18d/0x870
 [<ffffffff8100bc0e>] ? apic_timer_interrupt+0xe/0x20
 [<ffffffff81070ba8>] ? do_group_exit+0x58/0xd0
 [<ffffffff810857d6>] ? get_signal_to_deliver+0x1f6/0x460
 [<ffffffff8100a2d5>] ? do_signal+0x75/0x800
 [<ffffffff81083def>] ? kill_pid_info+0x3f/0x60
 [<ffffffff810a6cfb>] ? sys_futex+0x7b/0x170
 [<ffffffff8100aaf0>] ? do_notify_resume+0x90/0xc0
 [<ffffffff8100b3c1>] ? int_signal+0x12/0x17
---[ end trace 41979d2a5375f973 ]---
Comment 17 RHEL Product and Program Management 2012-07-10 02:06:04 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 18 RHEL Product and Program Management 2012-07-10 22:06:24 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Note You need to log in before you can comment on or make changes to this bug.