Bug 815634 - Ctrl+S for plurals hides which source is selected
Ctrl+S for plurals hides which source is selected
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
high Severity high
: ---
: 1.6-beta-1
Assigned To: Patrick Huang
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 02:32 EDT by David Mason
Modified: 2013-03-03 22:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-04-24 02:32:16 EDT
Description of problem:
When Ctrl+S (or "Save as fuzzy" button) is used on a plural translation, the source radio buttons do not show any source selected. "Copy source" buttons still behave as though the previously selected source is selected.

Version-Release number of selected component (if applicable):
1.6-alpha-1

How reproducible:
Always

Steps to Reproduce:
1.Open the editor and load a document with one or more plurals
2.Focus on a plural, select second source
3.Press Ctrl+S
4.Press "Copy source" button
  
Actual results:
Radio selectors stop displaying which source is selected. The previously selected source is copied.

Expected results:
Radio selectors always accurately show which source is selected.

Additional info:
This may be caused by something like this: http://stackoverflow.com/questions/8828271/handling-onclick-for-a-checkbox-in-a-celltable-header/10202270#10202270
Comment 1 Patrick Huang 2012-04-29 21:54:26 EDT
Committed into master:
https://github.com/zanata/zanata/commit/a1ee8a3fdb75e9782cba1e288e9b2df1d1895ac1
Comment 2 Joyce Chang 2012-05-03 21:42:52 EDT
verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120504-1030).

Note You need to log in before you can comment on or make changes to this bug.