Bug 815638 - Save dialog from filtering always saves as approved
Save dialog from filtering always saves as approved
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
medium Severity medium
: ---
: 1.6-beta-1
Assigned To: Patrick Huang
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 02:51 EDT by David Mason
Modified: 2013-03-03 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-alpha-3-SNAPSHOT (20120510-0019).
Doc Type: Bug Fix
Doc Text:
Cause Check any of the "Message filters" checkboxes and the save dialog from filtering always saves as approved. Consequence Fuzzy item will always be saved as approved. Fix A new button is provided to allow user save item as fuzzy. Result User can choose to save as approved or fuzzy.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-04-24 02:51:28 EDT
Description of problem:
When filtering, the user is prompted to save the translation they currently have focused. If they choose the save option, the translation is always saved in "Approved" state, even if it was previously "Fuzzy/Needs Review"

Version-Release number of selected component (if applicable):
1.6-alpha-1

How reproducible:
Always

Steps to Reproduce:
1.Load a document in the editor
2.Focus on a fuzzy translation and make a change to it
3.Check any of the "Message filters" checkboxes
4.On the dialog box, select the "Save Changes" option
  
Actual results:
The translation is saved as Approved

Expected results:
Translation should be saved with the existing state, or should always be saved as fuzzy, or the dialog should provide an additional button so the translator can choose which state to save with.

Additional info:
Comment 1 Patrick Huang 2012-04-29 21:39:20 EDT
A new button is provided to save as fuzzy.
Comment 2 Patrick Huang 2012-04-29 21:39:21 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Check any of the "Message filters" checkboxes and the save dialog from filtering always saves as approved.

Consequence
Fuzzy item will always be saved as approved.

Fix
A new button is provided to allow user save item as fuzzy.

Result
User can choose to save as approved or fuzzy.
Comment 3 Patrick Huang 2012-04-29 21:53:37 EDT
Committed into master:
https://github.com/zanata/zanata/commit/82d6012f9e7a65a096d5a7940b6dd75474e9473b
Comment 4 Joyce Chang 2012-05-04 00:35:32 EDT
Users don't actually have options to choose from save as approved/ save as fuzzy.

The available options now are:save changes/save as approved/discard changes/cancel filter.The Save changes button may be more intuitive by replacing as "Save as approved" since this is what this button intends to do.

Users will then have more clear options:save as fuzzy/save as approved/discard changes/cancel filter,to choose from. 
what you guys think?
Comment 5 Patrick Huang 2012-05-04 00:49:08 EDT
(In reply to comment #4)
> Users don't actually have options to choose from save as approved/ save as
> fuzzy.
> 
> The available options now are:save changes/save as approved/discard
> changes/cancel filter.The Save changes button may be more intuitive by
> replacing as "Save as approved" since this is what this button intends to do.
> 
> Users will then have more clear options:save as fuzzy/save as approved/discard
> changes/cancel filter,to choose from. 
> what you guys think?

Current options are: Save Changes/Save as Fuzzy/Discard Changes/Cancel filter
Comment 6 Joyce Chang 2012-05-04 01:57:22 EDT
oops, yeah what i meant is "Save Changes/Save as Fuzzy/Discard Changes/Cancel filter", sorry~~
Comment 7 Patrick Huang 2012-05-10 00:22:05 EDT
We don't want to use the word "approved" since plural text flow may not be saved as approved if targets contain empty string. So save changes will be fine.
Comment 8 Joyce Chang 2012-05-10 02:50:18 EDT
Good point,thanks for clarifying!! 

verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120510-0019).

Note You need to log in before you can comment on or make changes to this bug.