This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 815643 - Ctrl+Enter has to be input multiple times for subsequent plurals
Ctrl+Enter has to be input multiple times for subsequent plurals
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
medium Severity high
: ---
: 1.6
Assigned To: Alex Eng
Joyce Chang
:
: 818794 (view as bug list)
Depends On: 818794
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 03:00 EDT by David Mason
Modified: 2013-03-03 22:19 EST (History)
6 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-beta-2-SNAPSHOT (20120530-0019).
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-04-24 03:00:27 EDT
Description of problem:
When using Ctrl+Enter (or just Enter if the option is active) to move to the next plural translation within the same text flow, after it has been used once it will not work the second time, but will work the third time. The shortcut works as expected if it is pressed very quickly.

Version-Release number of selected component (if applicable):
1.6-alpha-1

How reproducible:
Always when done slow enough

Steps to Reproduce:
1.Open a workspace for a locale that has 3 or more plurals (e.g. pl)
2.Load a document with plurals into the editor
3.Select a text flow with plurals, select the first translation
4.Press Ctrl+Enter 5 times, waiting 0.5 seconds after each
  
Actual results:
Second and fourth times pressing Ctrl+Enter does not have any visible effect. Other times work as expected.

Expected results:
Ctrl+Enter always moves to next plural, or saves as approved when on the last plural.

Additional info:
Comment 1 Patrick Huang 2012-04-29 21:56:41 EDT
Committed in master:
https://github.com/zanata/zanata/commit/0c514990da0c2110429dce3eed633e82f2a99131
Comment 2 Joyce Chang 2012-05-03 22:30:46 EDT
Hi patrick, 

It didn't seem to work for Chrome, see Bug 818794
Comment 3 Alex Eng 2012-05-10 01:49:51 EDT
Fixed in Zanata version 1.6.0-alpha-3-SNAPSHOT. 

Requires further testing as issues happens randomly and according to server performance.

See https://github.com/zanata/zanata/commit/c71123d07eccfe61a69de7a22b4f2c12385bc863
Comment 4 Joyce Chang 2012-05-10 02:31:59 EDT
Hi Alex,
I tested it over two different servers and it would only work in a funny manner.It won't work when you try to move to next entry by hitting Ctrl+enter,unless you refresh the page. That is, Ctrl+enter works only when you refresh page after coming in workspace.   

The situation where it would work:
step 1: visit a document with plural forms using Chrome
step 2: try to move down by hitting Ctrl+enter(won't work here)
step 3: refresh page
step 4: hit Ctrl+enter again(now it would work like charm!!!!)
Comment 5 Alex Eng 2012-05-13 18:27:57 EDT
Joyce, 

This could be the javascript cached in your browser. Can you try again on both the same servers that you tested and confirm if the problem persist? 

You might want to try with new server after clearing your browser cache (CTRL+SHIFT+DELETE).
Comment 6 Joyce Chang 2012-05-14 19:43:24 EDT
still not working after clearing cahce 
btw, firefox works fine
Comment 7 Sean Flanigan 2012-05-28 20:57:27 EDT
*** Bug 818794 has been marked as a duplicate of this bug. ***
Comment 8 Joyce Chang 2012-05-29 22:05:41 EDT
(In reply to comment #4)
> Hi Alex,
> I tested it over two different servers and it would only work in a funny
> manner.It won't work when you try to move to next entry by hitting
> Ctrl+enter,unless you refresh the page. That is, Ctrl+enter works only when
> you refresh page after coming in workspace.   
> 
> The situation where it would work:
> step 1: visit a document with plural forms using Chrome
> step 2: try to move down by hitting Ctrl+enter(won't work here)
> step 3: refresh page
> step 4: hit Ctrl+enter again(now it would work like charm!!!!)

Another bug has been reported to track the issue above. see Bug 826318
Comment 9 Joyce Chang 2012-05-30 01:04:09 EDT
verified Zanata version 1.6.0-beta-2-SNAPSHOT (20120530-0019).

Note You need to log in before you can comment on or make changes to this bug.