Bug 815679 - software error shows when searching certs with old url
software error shows when searching certs with old url
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wei Shen
:
Depends On:
Blocks: 733411
  Show dependency treegraph
 
Reported: 2012-04-24 05:01 EDT by Wei Shen
Modified: 2014-06-22 21:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 00:22:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Shen 2012-04-24 05:01:32 EDT
Description of problem:
Dell vendor found this bug. 

https://hardware.redhat.com/list.cgi?product=Red+Hat+Hardware+Certification&search_type=&component=Red+Hat+Enterprise+Linux&version=5&bug_status=Certified&devel_whiteboard=dell&devel_whiteboard_type=allwordssubstr&quicksearch=&internal_whiteboard=Server

This url will result in software error:
can't use an undefined value as an ARRAY reference at Bugzilla/Search.pm line 179.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. click the url
2.
3.
  
Actual results:
  software error

Expected results:
   no error and certs returned

Additional info:
Comment 1 Wei Shen 2012-04-24 05:05:56 EDT
Created attachment 579794 [details]
the patch
Comment 2 Rob Landry 2012-04-24 12:57:00 EDT
Should we open a second bug for the cf_* remappings?
Comment 3 Wei Shen 2012-04-24 23:18:58 EDT
the root cause of this bug is some syntax errors in code, I don't think other cf_* are used in old code, so we should be ok
Comment 4 Rob Landry 2012-04-25 09:55:07 EDT
The cf_* are fields that exist now that didn't before.  Old links that refer to the fields without the cf_* will be ignored by the code right?  If this is correct should we open a BZ for the purpose of having the code correctly update the none cf_* field name to cf_* field name so that the desired result can be returned?
Comment 5 Tony Fu 2012-04-25 19:32:58 EDT
Comment on attachment 579794 [details]
the patch

the patch looks good for me
Comment 6 Wei Shen 2012-04-26 02:35:33 EDT
we can add a new bug for remapping, for now, I have verified this patch on web2
Comment 7 Wei Shen 2012-05-17 03:11:08 EDT
verified on partner
Comment 8 Tony Fu 2012-06-06 00:22:42 EDT
Verified on live.

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.