Bug 815721 - Auto installation doesn't reports error when the total size of storage_vol exceeds the disk volume
Auto installation doesn't reports error when the total size of storage_vol ex...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 07:10 EDT by yuanquan chen
Modified: 2016-04-26 09:46 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:12:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuanquan chen 2012-04-24 07:10:51 EDT
Description of problem:
The auto installation won't drop into emergency shell to report error
even the sum size of storage_vol bigger than disk volume size. 

The usb disk volume is 4GB, auto install with BOOTIF storage_init=usb storage_vol=:2000::20:2100:1000

After install, cannot see all lv:
[root@localhost admin]# lvs
  LV     VG     Attr     LSize    Pool Origin Data%  Move Log Copy%  Convert
  Config HostVG -wi-ao--   20.00m                                           
  Data   HostVG -wi-ao-- 1000.00m                                           
  Swap   HostVG -wi-ao--    1.95g                                           


Version-Release number of selected component (if applicable):
rhevh-6.3-20120419.0.el6

How reproducible:
100%

Steps to Reproduce:
1. add a 4GB usb disk to host
2. Boot the rhev-h from bootable media, edit kernel cmdline, add
"storage_init=usb storage_vol=:2000::20:2100:1000 local_boot"
3. press "Enter" to start rhev-h auto install
  
Actual results:
The installation goes on until all steps finish, then it reboots

Expected results:
It will drop into emergency shell to report the disk volume is too small
for the installation 

Additional info:
Comment 6 errata-xmlrpc 2012-07-19 10:12:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.