Bug 815746 - man "aeolus-image" needs to have a man page entry
man "aeolus-image" needs to have a man page entry
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta2
: ---
Assigned To: Mike Orazi
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 08:21 EDT by Rehana
Modified: 2012-12-04 10:05 EST (History)
7 users (show)

See Also:
Fixed In Version: rubygem-aeolus-cli-0.7.2-1.el6cf
Doc Type: Bug Fix
Doc Text:
The command 'man aeolus-image' shows no manual entry error when used in Fedora. The component to rubygem-aeolus-cli was reset. aeolus-image now has a manual page entry.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:05:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-04-24 08:21:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.login to aeolus CLI
2. issue the command
 man "aeolus-image" or man aeolus-image

  
Actual results:
Observed that the commands shows no manual entry error

 man "aeolus-image"
No manual entry for aeolus-image

Expected results:
Should have a man page entry

Additional info:

rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 Martyn Taylor 2012-08-15 11:02:27 EDT
this was done a while back. 

You can now open up the aeolus-image man page via:

man aeolus-image
Comment 3 Rehana 2012-09-20 06:11:08 EDT
Observed that still man aeolus-image gives the same output

[root@nec-em24-3 ~]# man aeolus-image
No manual entry for aeolus-image

on 
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch

setting it back to assigned.
Comment 4 Steve Linabery 2012-09-20 12:32:57 EDT
A couple of potentially interesting observations:

Note that on fedora, `man aeolus-image` displays the man page for aeolus-image-list. There is no separate man source for aeolus-image.

On rhel, `man aeolus-image-list` works fine.

Not sure what magic fedora uses to determine that man should display the aeolus-image-list man page when you invoke `man aeolus-image`, but that is what appears to be missing on RHEL.
Comment 5 Steve Linabery 2012-09-20 14:02:17 EDT
Looks like this is due to fedora using man-db and rhel using plain old man. The text of ./man/aeolus-image-list.1 uses aeolus-image for the program name, man page subject, etc. So that's what's getting indexed in /var/cache/man/index.db on fedora.
Comment 6 Steve Linabery 2012-09-21 12:15:19 EDT
reviewing it now, just checking that it installs properly everywhere.
Comment 7 Steve Linabery 2012-09-21 13:02:54 EDT
patch works for me. pushed to
8555dbe master
cbd054e 1.1
Comment 8 Steve Linabery 2012-09-21 13:41:38 EDT
setting component to rubygem-aeolus-cli since that's where the executable in question lives.
Comment 9 Aziza Karol 2012-09-25 02:01:21 EDT
aeolus-image has now a man page entry.

# man aeolus-image
aeolus-image(1)                  USER COMMANDS                 aeolus-image(1)

NAME
       aeolus-image - command line tool for managing images and related resources on the aeolus suite of tools

SYNOPSIS
       aeolus image [list|build|push|import|status] [-h]

DESCRIPTION
       aeolus-image  is a tool that allows users to manage images and related resources in their aeolus installation.  Such resources consist
       of:

       aeolus-image consists of 5 subcommands: list, build, push, import and status.

       Each command can also be called directly via ’aeolus-image’ or via ’aeolus-image-{subcommand}’

       For more information on each subcommand, you may run any of the following:
           man aeolus-{command}-{subcommand}
           aeolus-image {subcommand} --help
           aeolus-image-{subcommand} --help
           aeolus --help

OPTIONS
       -h, --help
              Get usage information for this tool and subcommands

FILES
       aeolus reads its configuration from ~/.aeolus-cli

       ~/.aeolus-cli
              This contains the URL and credentials for your admin user in aeolus-conductor.  If setup differs from default one, those should
              be changed accordingly. Conductor URL should be as follows https://<host_where_conductor_runs>/conductor/api

AUTHORS
       Martyn Taylor (mtaylor@redhat.com), Jason Guiditta (jguiditta@redhat.com)

SEE ALSO
       aeolus-image-build(1), aeolus-image-push(1), aeolus-image-list(1), aeolus-image-import(1), aeolus-image-status(1)

version 0.4                    December 20, 2011               aeolus-image(1)





verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 10 Dave Johnson 2012-11-02 09:56:46 EDT
good to go

aeolus-all-0.13.24-1.el6cf.noarch
aeolus-conductor-0.13.24-1.el6cf.noarch
aeolus-conductor-daemons-0.13.24-1.el6cf.noarch
aeolus-conductor-doc-0.13.24-1.el6cf.noarch
aeolus-configure-2.8.11-1.el6cf.noarch
rubygem-aeolus-cli-0.7.7-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 12 errata-xmlrpc 2012-12-04 10:05:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.