Bug 815770 - SELinux is preventing /usr/sbin/pppd from 'getattr' accesses on the socket Unknown.
SELinux is preventing /usr/sbin/pppd from 'getattr' accesses on the socket Un...
Status: CLOSED DUPLICATE of bug 815767
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e8e4fb74193b0de34ed95b38a4e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 09:37 EDT by ManFree
Modified: 2012-04-24 10:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 10:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ManFree 2012-04-24 09:37:18 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-7.fc16.i686
reason:         SELinux is preventing /usr/sbin/pppd from 'getattr' accesses on the socket Unknown.
time:           Tue Apr 24 21:37:06 2012

description:
:SELinux is preventing /usr/sbin/pppd from 'getattr' accesses on the socket Unknown.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that pppd should be allowed getattr access on the Unknown socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pppd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:pppd_t:s0
:Target Context                system_u:system_r:l2tpd_t:s0
:Target Objects                Unknown [ socket ]
:Source                        pppd
:Source Path                   /usr/sbin/pppd
:Port                          <Неизвестно>
:Host                          (removed)
:Source RPM Packages           ppp-2.4.5-18.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.1.0-7.fc16.i686 #1
:                              SMP Tue Nov 1 21:00:16 UTC 2011 i686 i686
:Alert Count                   1
:First Seen                    Вт. 24 апр. 2012 21:36:20
:Last Seen                     Вт. 24 апр. 2012 21:36:20
:Local ID                      f69cc593-a62b-4cc3-b879-ee6dce28ef71
:
:Raw Audit Messages
:type=AVC msg=audit(1335288980.979:127): avc:  denied  { getattr } for  pid=25936 comm="pppd" scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=socket
:
:
:type=SYSCALL msg=audit(1335288980.979:127): arch=i386 syscall=socketcall success=yes exit=0 a0=6 a1=bfbd6c30 a2=f5d2b0 a3=0 items=0 ppid=25932 pid=25936 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pppd exe=/usr/sbin/pppd subj=system_u:system_r:pppd_t:s0 key=(null)
:
:Hash: pppd,pppd_t,l2tpd_t,socket,getattr
:
:audit2allow
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:socket getattr;
:
:audit2allow -R
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:socket getattr;
:
Comment 1 Miroslav Grepl 2012-04-24 10:43:07 EDT

*** This bug has been marked as a duplicate of bug 815767 ***

Note You need to log in before you can comment on or make changes to this bug.