Bug 815775 - SELinux is preventing /usr/sbin/pppd from 'sendto' accesses on the unix_dgram_socket /tmp/openl2tp-event.sock.
SELinux is preventing /usr/sbin/pppd from 'sendto' accesses on the unix_dgram...
Status: CLOSED DUPLICATE of bug 815765
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c35b80af0e072ac80f1eb9cbbcd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 09:43 EDT by ManFree
Modified: 2012-04-24 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 11:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ManFree 2012-04-24 09:43:31 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-7.fc16.i686
reason:         SELinux is preventing /usr/sbin/pppd from 'sendto' accesses on the unix_dgram_socket /tmp/openl2tp-event.sock.
time:           Tue Apr 24 21:43:19 2012

description:
:SELinux is preventing /usr/sbin/pppd from 'sendto' accesses on the unix_dgram_socket /tmp/openl2tp-event.sock.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that pppd should be allowed sendto access on the openl2tp-event.sock unix_dgram_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pppd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:pppd_t:s0
:Target Context                system_u:system_r:l2tpd_t:s0
:Target Objects                /tmp/openl2tp-event.sock [ unix_dgram_socket ]
:Source                        pppd
:Source Path                   /usr/sbin/pppd
:Port                          <Неизвестно>
:Host                          (removed)
:Source RPM Packages           ppp-2.4.5-18.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux localhost.localdomain 3.1.0-7.fc16.i686 #1
:                              SMP Tue Nov 1 21:00:16 UTC 2011 i686 i686
:Alert Count                   1
:First Seen                    Вт. 24 апр. 2012 21:38:37
:Last Seen                     Вт. 24 апр. 2012 21:38:37
:Local ID                      17f032db-c756-4e34-8e84-3762e51fef32
:
:Raw Audit Messages
:type=AVC msg=audit(1335289117.124:131): avc:  denied  { sendto } for  pid=25936 comm="pppd" path="/tmp/openl2tp-event.sock" scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:system_r:l2tpd_t:s0 tclass=unix_dgram_socket
:
:
:type=SYSCALL msg=audit(1335289117.124:131): arch=i386 syscall=socketcall success=yes exit=EBADE a0=9 a1=bfbd69f0 a2=14e0fc a3=34 items=0 ppid=25932 pid=25936 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pppd exe=/usr/sbin/pppd subj=system_u:system_r:pppd_t:s0 key=(null)
:
:Hash: pppd,pppd_t,l2tpd_t,unix_dgram_socket,sendto
:
:audit2allow
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:unix_dgram_socket sendto;
:
:audit2allow -R
:
:#============= pppd_t ==============
:allow pppd_t l2tpd_t:unix_dgram_socket sendto;
:
Comment 1 Daniel Walsh 2012-04-24 11:29:20 EDT

*** This bug has been marked as a duplicate of bug 815765 ***

Note You need to log in before you can comment on or make changes to this bug.