Bug 815799 - Internal server error when Web UI calls pwpolicy_find with pkey_only option
Internal server error when Web UI calls pwpolicy_find with pkey_only option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 10:32 EDT by Dmitri Pal
Modified: 2012-06-20 09:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-2.2.0-12.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-04-24 10:32:37 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2676

Server returns internal server error when there exists 3 or more password policies.

Probably regression because of #2045

Log:
{{{
[Tue Apr 24 09:11:09 2012] [error] ipa: INFO: admin@VM-031.IDM.LAB.BOS.REDHAT.COM: group_find(None): SUCCESS
[Tue Apr 24 09:11:09 2012] [error] ipa: ERROR: non-public: KeyError: 'cospriority'
[Tue Apr 24 09:11:09 2012] [error] Traceback (most recent call last):
[Tue Apr 24 09:11:09 2012] [error]   File "/usr/lib/python2.6/site-packages/ipaserver/rpcserver.py", line 320, in wsgi_execute
[Tue Apr 24 09:11:09 2012] [error]     result = self.Command[name](*args, **options)
[Tue Apr 24 09:11:09 2012] [error]   File "/usr/lib/python2.6/site-packages/ipalib/frontend.py", line 438, in __call__
[Tue Apr 24 09:11:09 2012] [error]     ret = self.run(*args, **options)
[Tue Apr 24 09:11:09 2012] [error]   File "/usr/lib/python2.6/site-packages/ipalib/frontend.py", line 716, in run
[Tue Apr 24 09:11:09 2012] [error]     return self.execute(*args, **options)
[Tue Apr 24 09:11:09 2012] [error]   File "/usr/lib/python2.6/site-packages/ipalib/plugins/baseldap.py", line 1913, in execute
[Tue Apr 24 09:11:09 2012] [error]     entries.sort(self.entries_sortfn)
[Tue Apr 24 09:11:09 2012] [error]   File "/usr/lib/python2.6/site-packages/ipalib/plugins/pwpolicy.py", line 466, in sort_priority
[Tue Apr 24 09:11:09 2012] [error]     return cmp(int(x[1]['cospriority'][0]), int(y[1]['cospriority'][0]))
[Tue Apr 24 09:11:09 2012] [error] KeyError: 'cospriority'
[Tue Apr 24 09:11:09 2012] [error] ipa: INFO: admin@EXAMPLE.COM: pwpolicy_find(None, sizelimit=0, pkey_only=True): KeyError

}}}
Comment 2 Martin Kosek 2012-04-26 08:46:12 EDT
Fixed upstream:

master:
b137b7137176fbcc02db0b9b9fdf53a896fdd11a
c34136b0375aace93ee947cc45a3cbdc64b2e35c
e1f69625454fe1c023c0f4571bbb0a15efc15ccf

ipa-2-2:
2271e0a481889d1a7d5d8b71aa9dda73880dd3f2
a79b4cea94403eee74afd5e773be1ce6b48e29fc
71f4b2be541863e7e462867c550e0f4fa6ba2642

Note: paging for password policy page in the Web UI was disabled so that the password policy order is right (password policies are ordered by their priority).
Comment 6 Martin Kosek 2012-05-03 03:11:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 7 Namita Soman 2012-05-03 15:02:44 EDT
Verified using ipa-server-2.2.0-12.el6.x86_64

Was able to add 7 policies - and no internal server errors, and while adding used varying priorities, and all were listed in sorted order
Comment 9 errata-xmlrpc 2012-06-20 09:27:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.