Bug 815868 - Make ID UI bugs
Make ID UI bugs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pengfei Xue
:
Depends On: 723012
Blocks: 733411
  Show dependency treegraph
 
Reported: 2012-04-24 13:14 EDT by Rob Landry
Modified: 2012-06-06 00:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 00:51:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of radio knob for new vs. dropdown make (16.80 KB, image/png)
2012-04-25 15:16 EDT, Rob Landry
no flags Details

  None (edit)
Description Rob Landry 2012-04-24 13:14:48 EDT
Description of problem:

On the test server:

Create New Cert:

Make defaults to blank, blank should not be an option; behavior should mimic vendor and/or "Please Select A Make" something like this.

Some vendors have no make (Login Informatic for example), so make remains blank and not selectable, this will error if submitted.

Vendors without existing makes should be able to enter text for a new make similar to how a cert shows it.


Edit a Cert.

Vendors without make only have "Select a Make" in the drop down.

Clone a Cert.

Vendors without make only have "Select a Make" in the drop down.


All 3 pages:

I see no way for a vendor to enter/provide/request a new make.


Version-Release number of selected component (if applicable):

hwcert-3.2rh-20120423.1 ; version info as reported on web2 4/24.
Comment 1 Pengfei Xue 2012-04-25 02:11:50 EDT
(In reply to comment #0)
> 
> All 3 pages:
> 
> I see no way for a vendor to enter/provide/request a new make.

I think it's a good opportunity for vendor to add a new make when creating certs
Comment 2 Wei Shen 2012-04-25 02:36:11 EDT
vendors have no  permission to create a make.
Comment 3 Pengfei Xue 2012-04-25 02:51:57 EDT
discussed with weishen, we have two options for vendor:
1) add a unknown make in UI if that vendor has no valid makes yet, and require reviewers to add a new one through admin interface

2) allow vendor input make manually when creating a new cert

i prefer option 2, since it's fair for vendor to add a new one that he knows
Comment 4 Wei Shen 2012-04-25 02:56:06 EDT
I think we need a dummy make like "Unknown" for any vendor to choose, and make a comment to request make changed to what they want. 

We also should do make clean up first, because some makes which look more like test plans or vendor names would confuse the vendor who opens a new cert
Comment 6 Pengfei Xue 2012-04-25 07:27:49 EDT
Created attachment 580138 [details]
patch for make id ui
Comment 7 Rob Landry 2012-04-25 15:11:07 EDT
make id ui on demo site shows a enter new make for vendors without makes, but it doesn't provide this for vendors with makes.  Vendors should have permissions to create new makes.  These can then later be corrected.  The create, edit, and pass-through pages should all allow this.

A radio or other knob may be a way to help the tool decide which value to use, or even a special value in th drop down?
Comment 8 Rob Landry 2012-04-25 15:16:33 EDT
Created attachment 580256 [details]
screenshot of radio knob for new vs. dropdown make

This also avoids JS (which can annoy).
Comment 9 Rob Landry 2012-04-26 16:47:30 EDT
Feedback from web2's code today, calls itself hwcert-3.2rh-20120423.1

Editing an existing make in an existing cert does not default to the current value but goes to "select a make".

^^^ happens on the pass-through tab as well.

Create new cert shows blanks for make and does not auto check the make dropdown nor create new make regardless.

Selecting IBM for example, should auto select the dropdown radio and then a default template provided disable value of "Select Make" or something.

Selecting Login Informatic, should select add new makes and disable the dropdown row because they have no makes.  Adding a grayed auto erasing default text value like "Enter New Make" or something may help clarify the UI as well.
Comment 10 Tony Fu 2012-04-27 08:57:28 EDT
(In reply to comment #9)
> Feedback from web2's code today, calls itself hwcert-3.2rh-20120423.1
> 
> Editing an existing make in an existing cert does not default to the current
> value but goes to "select a make".
> 
> ^^^ happens on the pass-through tab as well.

It seems very hard to default the make to current value, since the make list is dynamically generated by js and dynamically change other fields according to the dynamically generated make field seems impossible to me.  I have tried to fix it for a while, but no luck.  Maybe someone can help me.  Personally, I think clicking "edit" goes to "select a make" is acceptable, since clicking "edit" supposes to change the make. 
> 
> Create new cert shows blanks for make and does not auto check the make dropdown
> nor create new make regardless.
When creating a new cert, after selecting "Provide Manually", the vendor and make should be changed to "select a vendor/make" and the dropdown radio is auto selected.
> 
> Selecting IBM for example, should auto select the dropdown radio and then a
> default template provided disable value of "Select Make" or something.
> 
> Selecting Login Informatic, should select add new makes and disable the
> dropdown row because they have no makes.  Adding a grayed auto erasing default
> text value like "Enter New Make" or something may help clarify the UI as well.
For the same reason of the default make selection to the current value, dynamically selecting make dropdown or "enter new make" according to make list seems very hard.

Anyway, thanks for the feedback.  I just post the current patch which is on web2.  This patch is already a big one and if we need to improve the web UI, we can work on top of this patch. 

I will continue to work on the UI improvement and any helps are highly appreciated.
Comment 11 Tony Fu 2012-04-27 08:58:39 EDT
Created attachment 580763 [details]
patch for make id ui according to rob's first comment
Comment 12 Rob Landry 2012-04-27 13:51:29 EDT
(In reply to comment #10)
> Personally, I think clicking "edit" goes to "select a make" is acceptable,
> since clicking "edit" supposes to change the make. 

Problem is it is a regression in usability from an edit field that would properly populate to a reasonable default to one that not only doesn't do this it also blinds the user to current saved value.

> Anyway, thanks for the feedback.  I just post the current patch which is on
> web2.  This patch is already a big one and if we need to improve the web UI, we
> can work on top of this patch. 
> 
> I will continue to work on the UI improvement and any helps are highly
> appreciated.

Edit and pass-through still need a radio to clarify to the user if the dropdown or text value will be stored.
Comment 13 Tony Fu 2012-04-30 23:07:32 EDT
Created attachment 581299 [details]
make id related UI changes
Comment 14 Rob Landry 2012-05-03 23:23:52 EDT
style="margin-left: 25px;" on the dropdown and text input helps clarify they belong to the radios.

If the js can auto select the matching radio when the drop down is selected or the text box typed in this helps reduce the need for the user to do it.

It would be better if the current text only version was hidden on the edit view and the 'current value' option was populated with the make.
Comment 15 Tony Fu 2012-05-04 04:29:41 EDT
(In reply to comment #14)
> style="margin-left: 25px;" on the dropdown and text input helps clarify they
> belong to the radios.
> 
> If the js can auto select the matching radio when the drop down is selected or
> the text box typed in this helps reduce the need for the user to do it.
> 
> It would be better if the current text only version was hidden on the edit view
> and the 'current value' option was populated with the make.

Update the code on web2, please have a look
Comment 16 Tony Fu 2012-05-14 21:44:01 EDT
Verified on web2
Comment 20 Tony Fu 2012-06-06 00:51:20 EDT
verified on live.

Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.