Bug 816002 - Strange error message:
Strange error message:
Status: CLOSED DEFERRED
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 22:54 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:35:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-04-24 22:54:19 EDT
I had a line like this in my content spec:

  JCA Adapter [N, Concept

When pushing, I got this cryptic error message:


[jwulf@dhcp-1-77 Messaging_Installation_and_Configuration_Guide]$ csprocessor push
CSProcessor client version: 0.23.2
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

ERROR: Index: 215, Size: 214
ERROR: The Content Specification is not valid.


I was able to figure out the cause of the error, but perhaps the message could be made more informative?






cspclient-0.23.2-1.noarch
OS: Fedora release 15 (Lovelock)

JAVA: java version "1.7.0_01"
Java(TM) SE Runtime Environment (build 1.7.0_01-b08)
Java HotSpot(TM) 64-Bit Server VM (build 21.1-b02, mixed mode)
Comment 1 Lee Newson 2012-04-25 03:13:56 EDT
That is a really strange error and not an error message I've actually coded directly. It looks like an IndexOutOfBounds Exception error message. I'll take a look at it tomorrow or Friday.
Comment 2 Lee Newson 2012-04-25 21:27:47 EDT
I require one bit of information to help debug the cause of this. Could you post the snippet of the spec where this occurred. As I can't replicate it easily, so if you could provide where that would be great.
Comment 3 Joshua Wulf 2012-05-10 21:47:36 EDT
JCA Adapter [N, Concept

was the line.
Comment 4 Lee Newson 2012-05-10 22:12:54 EDT
Adding again NEED_INFO again. I said I require the Content Spec snippet (preferably the entire spec) not the line. I've tested just doing that and as I said I can't replicate it.
Comment 5 Joshua Wulf 2012-05-15 06:53:57 EDT
Sorry, next time I'll hang on to it.

Happy to close this and reopen it if it reappears.
Comment 6 Lee Newson 2012-06-21 21:09:49 EDT
I think I found the issue and should be fixed as part of Bug #834387

Note You need to log in before you can comment on or make changes to this bug.