Bug 816009 - move crashkernel auto reserve theshold to 2G
move crashkernel auto reserve theshold to 2G
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
6.3
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Roman Rakus
Guangze Bai
:
Depends On:
Blocks: 915729
  Show dependency treegraph
 
Reported: 2012-04-24 23:36 EDT by Dave Young
Modified: 2015-02-08 16:59 EST (History)
6 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.5-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:39:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Young 2012-04-24 23:36:19 EDT
Description of problem:

X86 kdump crashkernel=auto threshold changed from 4G to 2G, so system-config-kdump also need a change.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Roman Rakus 2012-04-25 08:58:38 EDT
(In reply to comment #0)
> Description of problem:
> 
> X86 kdump crashkernel=auto threshold changed from 4G to 2G, so
> system-config-kdump also need a change.
Thanks for information.
Is only x86 changed or also ppc (or any other)?
Comment 3 Dave Young 2012-04-25 23:21:36 EDT
(In reply to comment #2)
> (In reply to comment #0)
> > Description of problem:
> > 
> > X86 kdump crashkernel=auto threshold changed from 4G to 2G, so
> > system-config-kdump also need a change.
> Thanks for information.
> Is only x86 changed or also ppc (or any other)?

Hi, only x86 changed.

BTW, for the total memsize, kernel usually report less than actual physical
memory module size. So we did same as kernel side in firstboot.py: roundup
totalsize to 128M when we compare with the threshold.

I guess this is also necessary for system-config-kdump?
Comment 4 IBM Bug Proxy 2012-04-27 08:30:25 EDT
(In reply to comment #7)
> > Thanks for information.
> > Is only x86 changed or also ppc (or any other)?

For s390x we will use 4 GiB (see Red Hat bug #815599). Could you please adjust firstboot and system-config-kdump accordingly?
Comment 5 Roman Rakus 2012-05-02 07:08:46 EDT
(In reply to comment #4)
> (In reply to comment #7)
> > > Thanks for information.
> > > Is only x86 changed or also ppc (or any other)?
> 
> For s390x we will use 4 GiB (see Red Hat bug #815599). Could you please adjust
> firstboot and system-config-kdump accordingly?

s-c-kdump yes. In this bug.
Comment 7 Roman Rakus 2012-05-02 11:14:57 EDT
Fixed in system-config-kdump-2.0.5-6.el6.
Comment 10 Georg Markgraf 2012-05-03 11:03:14 EDT
Roman, 
do you (or Dan) handle the adjustment in first boot via this bug or will you create a clone for first boot?
Comment 11 IBM Bug Proxy 2012-05-03 11:40:57 EDT
(In reply to comment #12)
> Roman,
> do you (or Dan) handle the adjustment in first boot via this bug or will you
> create a clone for first boot?

The following RHBZ reflects firstboot:

Bug 805040 - firstboot contains kdump which is not support on s390x
Comment 18 IBM Bug Proxy 2012-06-11 04:30:35 EDT
Hi

I verified this feature on RHEL6.3-RC1 and if system memory less than 4gb on system-config-kdump user is not able to use automatic configuration but if system memory is 4gb than it works

Regards
Praveen
Comment 20 errata-xmlrpc 2012-06-20 09:39:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0824.html
Comment 21 IBM Bug Proxy 2015-02-08 16:59:21 EST
------- Comment From michael.holzheu@de.ibm.com 2012-04-27 12:28 EDT-------

------- Comment From brueckner@de.ibm.com 2012-05-03 15:33 EDT-------

------- Comment From Praveen.Pandey@in.ibm.com 2012-06-11 08:21 EDT-------

Note You need to log in before you can comment on or make changes to this bug.