Bug 816047 - SVN connector fails to install.
SVN connector fails to install.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 03:03 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 06:50:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-25 03:03:03 EDT
What steps will reproduce the problem?
1. 
2. 
3. 


-- Error Details --
Date: Wed Apr 25 09:02:00 CEST 2012
Message: Problems resolving provisioning plan.
Severity: Warning
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.equinox.p2.director
Session Data:
eclipse.buildId=I20120417-1000
java.version=1.7.0_b147-icedtea
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean -debug -consolelog


-- Error Details --
Date: Wed Apr 25 09:02:00 CEST 2012
Message: Unable to satisfy dependency from org.polarion.eclipse.team.svn.connector.svnkit16 2.3.0.I20120413-1700 to bundle org.eclipse.team.svn.core 0.7.9.I20120413-1700.
Severity: Warning
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.equinox.p2.director

-- Error Details --
Date: Wed Apr 25 09:02:00 CEST 2012
Message: Unable to satisfy dependency from org.polarion.eclipse.team.svn.connector.svnkit16.feature.group 2.3.0.I20120413-1700 to org.eclipse.team.svn.feature.group [0.7.9.I20120413-1700,1.0.0).
Severity: Warning
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.equinox.p2.director

-- Error Details --
Date: Wed Apr 25 09:02:00 CEST 2012
Message: Unable to satisfy dependency from org.polarion.eclipse.team.svn.connector.feature.group 2.3.0.I20120413-1700 to org.eclipse.team.svn.feature.group [0.7.9.I20120413-1700,1.0.0).
Severity: Warning
Product: Eclipse Platform 4.2.0.v20120403-1921 (org.eclipse.platform.ide)
Plugin: org.eclipse.equinox.p2.director
Comment 1 Krzysztof Daniel 2012-04-30 06:30:31 EDT
The same error message put in a slightly more understandable way:

Missing requirement: Subversive SVN 1.6 SVN Kit Connector 2.3.0.I20120413-1700 (org.polarion.eclipse.team.svn.connector.svnkit16 2.3.0.I20120413-1700) requires 'bundle org.eclipse.team.svn.core 0.7.9.I20120413-1700' but it could not be found
Comment 2 Krzysztof Daniel 2012-04-30 06:50:50 EDT
The problem is caused by the fact that Juno M6 update site is outdated in relation to polarion update site from where svn connectors are fetched. Closing as notabug, as using up-to-date update sites works fine.

The SVN should be fetched from here:
http://download.eclipse.org/technology/subversive/0.7/update-site/

Note You need to log in before you can comment on or make changes to this bug.