Bug 816052 - [glusterfs-3.3.0qa38] - remove-brick without start|stop|status|commit should display the usage message
[glusterfs-3.3.0qa38] - remove-brick without start|stop|status|commit should...
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 03:22 EDT by M S Vishwanath Bhat
Modified: 2013-12-18 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 03:33:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2012-04-25 03:22:21 EDT
Description of problem:
Currently remove-brick command without any options like start|stop|status|commit does commit force by default. Ideally when none of the options are given a usage message should be thrown to the console.

Version-Release number of selected component (if applicable):
glusterfs-3.3.0qa38

How reproducible:
Always

Steps to Reproduce:
1. Create and start a distribute volume.
2. Create some data on the mountpoint.
3. run remove-brick without any start|stop|status|commit options.
  
Actual results:
[root@QA-29 ~]# gluster v remove-brick hosdu 172.17.251.68:/data/bricks/hosdu_brick2
Removing brick(s) can result in data loss. Do you want to Continue? (y/n) y
Remove Brick commit force successful

Expected results:
Since user has not provided any options Usage message like below should be displayed.

Usage: volume remove-brick <VOLNAME> [replica <COUNT>] <BRICK> ... {start|pause|abort|status|commit|force}
Comment 1 shishir gowda 2012-04-25 03:33:00 EDT
This is not a bug.
This is needed for backward compatibility.

Note You need to log in before you can comment on or make changes to this bug.