Bug 816055 - Document 3GB Memory Allocation limit on 32-bit systems
Document 3GB Memory Allocation limit on 32-bit systems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
Development
Unspecified Unspecified
unspecified Severity unspecified
: 2.2
: ---
Assigned To: Joshua Wulf
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 03:25 EDT by Leonid Zhaldybin
Modified: 2014-11-09 17:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 23:13:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Zhaldybin 2012-04-25 03:25:58 EDT
Description of problem:
Apparently, 32-bit broker is unable to allocate more than ~3GB of memory, which is not a bug but an obvious restriction (see bug 756790). Nevertheless, this restriction is not mentioned in the user documentation.

  
Actual results:
Memory allocation restriction for 32-bit broker is not described in the MRG documentation.

Expected results:
Memory allocation restriction for 32-bit broker is described properly in the documentation.

Additional info:
Comment 3 Andrew Stitcher 2012-07-31 10:08:00 EDT
I think the user process memory limit depends on what kind of kernel you are running: a regular 32 bit kernel will only allow a user process to allocate 3Gb (because 1Gb of memory space is reserved for the kernel itself). However I think a PAE kernel will allow a user process to allocate the full 4Gb of memory space. Because in that case the kernel run in its own memory space (but there is a heavier penalty paid for switching from user to kernel mode).

Also note that the 3Gb limit includes all queues and internal data for the qpid broker as well as all of the program code and libraries used so that substantially less than 3Gb would be available for a single queue.
Comment 4 Cheryn Tan 2012-09-19 22:54:15 EDT
Released for MRG 2.2

Note You need to log in before you can comment on or make changes to this bug.