Bug 816219 - fv storage and network tests may fail for multiple devices on guest
fv storage and network tests may fail for multiple devices on guest
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-25 10:27 EDT by Greg Nichols
Modified: 2015-02-08 16:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fvtest.py patch to accept a passing result on any device for the intended test (1.43 KB, patch)
2012-04-25 10:30 EDT, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0711 normal SHIPPED_LIVE v7 bug fix and enhancement update 2012-06-05 21:26:37 EDT

  None (edit)
Description Greg Nichols 2012-04-25 10:27:01 EDT
Description of problem:

The fv tests, particularly fv_storage and fv_network may fail when multiple devices exist on the guest in cases where they should pass.  For example,
some guest images have disks hda and hdb.  v7 running on the guest may schedule two storage tests, one for each disk, if they appear to be on different controllers.   The hdb test will fail, as it is the v7 data image, and in-use.  The fv_storage test may pick up this failed result even though hda's storage test passed.

Version-Release number of selected component (if applicable):

v7 1.5


How reproducible:

When newer guest images are used, such as v7x86_64-20120424.img.tar.bz2
Comment 1 Greg Nichols 2012-04-25 10:30:03 EDT
Created attachment 580181 [details]
fvtest.py patch to accept a passing result on any device for the intended test
Comment 6 Caspar Zhang 2012-06-04 04:04:59 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 8 errata-xmlrpc 2012-06-05 17:37:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.