Bug 816319 - Single condition at a time
Single condition at a time
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 15:22 EDT by eric@christensenplace.us
Modified: 2012-08-17 01:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 01:04:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2012-04-25 15:22:58 EDT
Description of problem: If I'm writing a document that may have multiple conditions that I would like to publish, Publican will only support publishing a single condition at a time.

Version-Release number of selected component (if applicable): 2.8
Comment 1 Ruediger Landmann 2012-04-25 19:51:28 EDT
(Not a bug in our packaging of Publican, moving upstream)

Hi -- this is actually how DocBook conditions are supposed to work, and I agree it's a little counter-intuitive. 

They "profile" the output by removing any element that has a condition set on it, when that condition is different from the one specified for the document. 

To specify content to appear only in certain, specific versions of a document, set those multiple conditions as a comma-separated list in the "condition" attribute on that element. When any one of those conditions is met, Publican includes that element in the build. 

There's an example of how to do this in the Publican User Guide.

If that doesn't help, maybe reply back here with an example of where it's going wrong for you.

Cheers
Rudi :)

Note You need to log in before you can comment on or make changes to this bug.