Bug 816345 - Double title on abstract
Double title on abstract
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 16:34 EDT by Deon Ballard
Modified: 2013-07-04 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.1.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 02:05:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
double abstract title (40.21 KB, image/png)
2012-04-25 16:34 EDT, Deon Ballard
no flags Details

  None (edit)
Description Deon Ballard 2012-04-25 16:34:13 EDT
Created attachment 580272 [details]
double abstract title

Description of problem:
If one manually sets a title on an abstract, then two titles are created in the HTML output, one in the proper <h6> tag and then one in an <h1> tag. I've attached a screenshot.

Version-Release number of selected component (if applicable):
publican-2.8-2.el6eng.x86_64

How reproducible:
Always.

Actual results:
There are two titles displayed for the abstract title (with different formats).

Expected results:
There should be one, properly formatted title that fits the explicit <title> value.
Comment 1 Ruediger Landmann 2012-04-25 19:45:34 EDT
This is unlikely to have anything to do with Fedora's packaging of Publican; moving upstream.
Comment 2 Ruediger Landmann 2012-11-27 00:42:03 EST
Confirmed that this is still an issue in publican-3.0.0-0.fc17.noarch and also that if I build a doc just with the DocBook stylesheets and xsltproc, it doesn't happen.
Comment 3 Ruediger Landmann 2012-11-27 00:54:44 EST
Deon, to help us triage this, can you describe the circumstances under which we'd want to set a title on an <abstract>? It seems like a pretty well established convention.
Comment 4 Deon Ballard 2013-01-28 10:59:31 EST
Sorry, I missed the NEED_INFO request last autumn.

This really is not an established convention because not every document in real life uses an abstract. Many articles wouldn't (except, of course, academic articles, but that's not the case here). For example, why should release notes *require* an abstract? Or, say, a getting started guide. In this example, the doc is only a list of ulinks to all procedures in all JON guides. "Abstract" really doesn't make sense in that context. It's only used because publican requires it to build. I was attempting to use the "abstract" section as a summary, but make it clear that there is no further text in the doc.

The usage convention for other elements is that a title can be set manually. Even titles with automatic text -- like <note> -- can be overridden. 

The problem here is that when I put in the manual text, instead of printing one title, it prints two. If I use the automatic abstract title, it prints only one title line. It is a processing problem.
Comment 5 Jeff Fearn 2013-03-08 01:23:37 EST
We pulled out lots of overrides from our XSL for 3.1, is this still an issue?

Note You need to log in before you can comment on or make changes to this bug.