Bug 816444 - SELinux is preventing /usr/sbin/gpsd from 'setattr' accesses on the chr_file ttyUSB2.
SELinux is preventing /usr/sbin/gpsd from 'setattr' accesses on the chr_file ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:eb65323a8e92b4e35e63212c95f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 01:14 EDT by Sergei LITVINENKO
Modified: 2012-04-26 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 09:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2012-04-26 01:14:23 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.2-6.fc16.i686.PAE
reason:         SELinux is preventing /usr/sbin/gpsd from 'setattr' accesses on the chr_file ttyUSB2.
time:           Чт. 26 апр. 2012 08:13:42

description:
:SELinux is preventing /usr/sbin/gpsd from 'setattr' accesses on the chr_file ttyUSB2.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gpsd should be allowed setattr access on the ttyUSB2 chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gpsd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:gpsd_t:s0
:Target Context                system_u:object_r:usbtty_device_t:s0
:Target Objects                ttyUSB2 [ chr_file ]
:Source                        gpsd
:Source Path                   /usr/sbin/gpsd
:Port                          <Неизвестно>
:Host                          (removed)
:Source RPM Packages           gpsd-2.95-7.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-6.fc16.i686.PAE #1 SMP
:                              Sat Apr 21 13:02:14 UTC 2012 i686 i686
:Alert Count                   20
:First Seen                    Пт. 13 апр. 2012 17:39:21
:Last Seen                     Чт. 26 апр. 2012 08:08:03
:Local ID                      4586d470-c0e7-4d0a-b0b8-fddbe6465c42
:
:Raw Audit Messages
:type=AVC msg=audit(1335420483.815:33): avc:  denied  { setattr } for  pid=1194 comm="gpsd" name="ttyUSB2" dev="devtmpfs" ino=18989 scontext=system_u:system_r:gpsd_t:s0 tcontext=system_u:object_r:usbtty_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1335420483.815:33): arch=i386 syscall=chmod success=no exit=EACCES a0=bfe03f18 a1=21b0 a2=6 a3=bfe00edc items=0 ppid=1 pid=1194 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=gpsd exe=/usr/sbin/gpsd subj=system_u:system_r:gpsd_t:s0 key=(null)
:
:Hash: gpsd,gpsd_t,usbtty_device_t,chr_file,setattr
:
:audit2allow
:
:#============= gpsd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow gpsd_t usbtty_device_t:chr_file setattr;
:
:audit2allow -R
:
:#============= gpsd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow gpsd_t usbtty_device_t:chr_file setattr;
:
Comment 1 Daniel Walsh 2012-04-26 09:40:18 EDT
Looks like this is fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.