Bug 816452 - 【virtio-win][balloon]Uninstall balloon driver from Device Manager leads to BSOD after changing balloon value in monitor
【virtio-win][balloon]Uninstall balloon driver from Device Manager leads to BS...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 02:02 EDT by Min Deng
Modified: 2013-02-28 07:59 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 07:59:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
7-32 (21.73 KB, image/png)
2012-05-31 05:07 EDT, Min Deng
no flags Details
28R2 (18.79 KB, image/png)
2012-05-31 05:09 EDT, Min Deng
no flags Details

  None (edit)
Description Min Deng 2012-04-26 02:02:17 EDT
Description of problem:
Uninstalling balloon driver from device manager leads to BSOD after doing a series actions of reducing balloon values.
 
Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-27
How reproducible:
Tried the bz for three times,all can reproduce the issue

Steps to Reproduce:
1.Boot up guest 
  /usr/libexec/qemu-kvm -m 4G -smp 2 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -drive file=win2k8-64-run.raw,format=raw,if=none,id=drive-virtio0,cache=none,werror=stop,rerror=stop -device ide-drive,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0 -uuid 7a82fd37-b740-4105-8757-43b8aadce8b9 -monitor stdio -drive file=disk1.raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -spice port=5952,disable-ticketing -vga qxl -device virtio-balloon-pci,id=balloon1
2.
 Reducing balloon value from monitor
 eg,
(qemu) balloon 100
(qemu) balloon 2000
(qemu) balloon 1800
(qemu) balloon 1600
(qemu) balloon 1700
(qemu) balloon 1500
(qemu) info balloon
balloon: actual=2616
(qemu) stop
handle_dev_input: stop
(qemu) cont
handle_dev_input: start

3.Go to Device Manager and uninstall the balloon driver
  
Actual results:
BSOD occurred
Expected results:
The guest should works well
Additional info:
Got three dumps and will upload them to the bug.
Comment 3 Min Deng 2012-04-26 06:39:36 EDT
  Similar issue can be found on window 2k3 32 bits,so please also have a look and I will put the related dump to the same location - comments 1 .Any issues feel free let me know,thanks

Best Regards,
Min
Comment 4 Ronen Hod 2012-05-01 18:48:20 EDT
Dor, Vadim and I decided to postpone this bug to 6.4
Comment 5 Min Deng 2012-05-31 04:47:27 EDT
Hi,

  It also occurs while upgrading balloon driver from 6.2 to 6.3 during memory balloon on 6.2.z host
  will upload related dump files to the bug.

Thanks 
Min
Comment 7 Min Deng 2012-05-31 05:07:38 EDT
Created attachment 587992 [details]
7-32
Comment 8 Min Deng 2012-05-31 05:09:21 EDT
Created attachment 587993 [details]
28R2
Comment 9 Min Deng 2012-05-31 06:14:55 EDT
Reproduce the issue on windows 7 32 ,windows 2008 R2 and windows 2008 64.
Comment 10 Mike Cao 2012-05-31 06:49:01 EDT
Move back to original bug title due to the issue was orginal found in RHEL6.3 hosts.

When QE verify this issue , need to check driver update test as well .

Mike
Comment 11 Vadim Rozenfeld 2012-06-19 15:35:30 EDT
please check with the most recent driver available at
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/29/win/virtio-win-prewhql-0.1.zip
Comment 13 Min Deng 2012-06-21 03:10:12 EDT
 
  Reproduced it on virtio-win-prewhql-0.1-27,
  Steps,please refer to comments 0
  Verified on virtio-win-prewhql-0.1-29
  Steps,please refer to comment 0 and testing also included driver's upgrading
  Base on above the bug is fixed on virtio-win-prewhql-0.1-29

Thanks.
Min
Comment 15 Mike Cao 2012-08-02 22:40:42 EDT
According to comment #13 ,move status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.