Bug 816453 - Server URL, <url> in zanata.xml, url in zanata.in should be consistent
Server URL, <url> in zanata.xml, url in zanata.in should be consistent
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity medium
: ---
: 1.6-beta-1
Assigned To: David Mason
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 02:03 EDT by Ding-Yi Chen
Modified: 2013-03-03 22:19 EST (History)
3 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-alpha-3-SNAPSHOT (20120511-0019).
Doc Type: Bug Fix
Doc Text:
Cause Sample zanata.xml and for a project and sample zanata.ini for a user sometimes had different URLs (e.g. http://example.com vs. https://example.com). This was due to the zanata.xml sample using the server configured URL, but the zanata.ini using the current navigation URL. Consequence Zanata clients would not properly associate user configuration from zanata.ini with the server specified in zanata.xml when the defaults from the sample configuration documents were used, leading to errors about missing user configuration information. Fix The sample zanata.ini was updated to use the server configured URL. Result URL is now consistent between zanata.ini and zanata.xml, so clients will properly detect user configuration when default server URLs in sample configuration documents are used.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-04-26 02:03:49 EDT
Description of problem:
<url> in zanata.xml, url for zanata.ini from user profile should respect the Server URL from Server Configuration if server URL exists, or use the same logic to "guess" the server URL.

However, <url> from zanata.xml seems to respect Sever URL configuration,
while url for zanata.ini from user profile seems to have it's own way to determining server URL.

For example
Server Configuration -> Server URL shows: https://zanata.server.org/
<url> in zanata.xml shows: https://zanata.server.org/
But url for zanata.ini from user profile shows: http://zanata.server.org/

Version-Release number of selected component (if applicable):
Zanata version 1.6.0-alpha-1 (20120419-0011)

How reproducible:
Always. 
It seems to associate with address redirection.


Steps to Reproduce:
1. Sign in as admin
2. In Server Configuration -> Server URL, 
   input https://zanata.server.org/
3. Click "Profile" on the menu bar
4. Look at the url for zanata.ini
  
Actual results:
url for zanata.ini shows http://zanata.server.org/

Expected results:
url for zanata.ini should be identical from sever URL in server configuration.


Additional info:
Comment 1 David Mason 2012-04-26 02:11:25 EDT
Updated to use server configured URL in zanata.ini sample. Server configured URL was already being used for generated zanata.xml.

See https://github.com/zanata/zanata/commit/78ec49f366896c1df64f54a244b0d9d4e1c483af
Comment 2 Joyce Chang 2012-05-11 01:52:01 EDT
verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120511-0019).
Comment 3 David Mason 2012-06-05 23:35:16 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Sample zanata.xml and for a project and sample zanata.ini for a user sometimes had different URLs (e.g. http://example.com vs. https://example.com). This was due to the zanata.xml sample using the server configured URL, but the zanata.ini using the current navigation URL.

Consequence
Zanata clients would not properly associate user configuration from zanata.ini with the server specified in zanata.xml when the defaults from the sample configuration documents were used, leading to errors about missing user configuration information.

Fix
The sample zanata.ini was updated to use the server configured URL.

Result
URL is now consistent between zanata.ini and zanata.xml, so clients will properly detect user configuration when default server URLs in sample configuration documents are used.

Note You need to log in before you can comment on or make changes to this bug.