Bug 816534 - FTBFS: build failure on PPC, f_mmp_garbage self check failed
FTBFS: build failure on PPC, f_mmp_garbage self check failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 06:48 EDT by Karsten Hopp
Modified: 2012-07-10 06:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 06:44:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-04-26 06:48:32 EDT
Description of problem:
f_mke2fs2b: mke2fs version 0.2b created filesystem: ok
f_mmp: disable MMP with tune2fs after e2fsck killed: ok
f_mmp_garbage: repair MMP when it is corrupted: ./f_mmp_garbage/script: line 25: 39999 Killed                  $DEBUGFS -w -R "set_mmp_value magic 0x12345678" $TMPFILE >> $test_name.log 2>&1
failed
f_noroot: missing root directory: ok
f_okgroup: 8193 block long filesystem: ok
....
117 tests succeeded	1 tests failed

Version-Release number of selected component (if applicable):
e2fsprogs-1.42.2-6.fc18

Steps to Reproduce:
1. ppc-koji build --scratch f18 e2fsprogs-1.42.2-6.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=513720
:
Comment 1 Eric Sandeen 2012-04-26 15:43:11 EDT
Weird, a manual build worked ok...
Comment 2 Karsten Hopp 2012-04-27 09:28:58 EDT
PPC finished, but PPC64 got stuck at another test if you're talking about http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=515668
Comment 3 Eric Sandeen 2012-04-27 10:53:51 EDT
yeah, that's one I launched which got stuck.  I local rpm rebuild worked fine on an F17 box.  And a local rawhide mock build worked too:

[mockbuilder@localhost sandeen]$ /usr/bin/mock -r fedora-rawhide-ppc64 --rebuild e2fsprogs-1.42.2-6.fc18.src.rpm 
INFO: mock.py version 1.1.21 starting...
State Changed: init plugins
INFO: selinux enabled
State Changed: start
INFO: Start(e2fsprogs-1.42.2-6.fc18.src.rpm)  Config(fedora-rawhide-ppc64)
State Changed: lock buildroot
State Changed: clean
INFO: chroot (/var/lib/mock/fedora-rawhide-ppc64) unlocked and deleted
State Changed: unlock buildroot
State Changed: init
State Changed: lock buildroot
Mock Version: 1.1.21
INFO: Mock Version: 1.1.21
INFO: calling preinit hooks
INFO: enabled root cache
State Changed: unpacking root cache
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled ccache
State Changed: running yum
State Changed: unlock buildroot
INFO: Installed packages:
State Changed: setup
State Changed: build
INFO: Done(e2fsprogs-1.42.2-6.fc18.src.rpm) Config(fedora-rawhide-ppc64) 7 minutes 18 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-ppc64/result
State Changed: end

So, um ....
Comment 4 Karsten Hopp 2012-04-27 11:29:19 EDT
do you have selinux=enforcing on your machine ? That's what our builders are using.
Comment 5 Eric Sandeen 2012-04-27 15:21:24 EDT
Just built it again in mock on a rhel6 ppc64 box from dwa; selinux is enforcing.  Passed ... again.
Comment 6 Eric Sandeen 2012-04-27 16:41:16 EDT
And now http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=519177
 just completed successfully.  No idea what's going on here...

I can try a local mock build a few times & see if I can hit the failure - at best it seems intermittent....
Comment 7 Eric Sandeen 2012-07-06 16:19:19 EDT
Does this problem persist?
Comment 8 Karsten Hopp 2012-07-10 06:44:47 EDT
doesn't look like it, we are on the same NVR as the primary archs now:
    koji updates: e2fsprogs-1.42.3-2.fc17
ppc-koji updates: e2fsprogs-1.42.3-2.fc17
    ppc-koji F18: e2fsprogs-1.42.4-1.fc18
        koji F18: e2fsprogs-1.42.4-1.fc18

Note You need to log in before you can comment on or make changes to this bug.