Bug 816545 - no sound on Front Mic on 82801JI (ICH10 Family)
no sound on Front Mic on 82801JI (ICH10 Family)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: alsa-lib (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Kysela
Ken Benoit
:
Depends On:
Blocks: 1269638
  Show dependency treegraph
 
Reported: 2012-04-26 07:15 EDT by Tomas Pelka
Modified: 2015-10-29 09:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 09:01:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2012-04-26 07:15:43 EDT
Description of problem:
no sound on recording from Front Mic, just noise

Version-Release number of selected component (if applicable):
kernel-2.6.32-262.el6
alsa-lib-1.0.22-3.el6

How reproducible:
100%

Steps to Reproduce:
1. arecord rec.wav
2. aplay rec.wav
3.
  
Actual results:
nothing except noise recorded 

Expected results:
should record sound

Additional info:
rear mic works just fine

00:1f.0 ISA bridge [0601]: Intel Corporation 82801JIR (ICH10R) LPC Interface
Controller [8086:3a16]
 Subsystem: Hewlett-Packard Company Device [103c:1309]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: [e0] Vendor Specific Information <?>
 Kernel modules: iTCO_wdt

alsa-info at
http://www.alsa-project.org/db/?f=19b3be2d065c5cd5fa93c557a4ed01b2adf496c9
Comment 1 Jaroslav Kysela 2012-04-26 09:43:58 EDT
Have you tried to set 'Input Source' to 'Front Mic' in the alsamixer (F4 key - capture - panel)?
Comment 2 Suzanne Yeghiayan 2012-05-01 11:10:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 3 Tomas Pelka 2012-05-15 05:08:30 EDT
OK I can hear some noise from fornt mic but its quality is very very poor.

Can I debug it somehow?
Comment 4 RHEL Product and Program Management 2012-07-10 02:45:50 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 19:04:06 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-09-07 01:20:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Jaroslav Kysela 2015-10-19 02:25:19 EDT
Could you retest with latest RHEL6 kernel ?
Comment 8 Ken Benoit 2015-10-29 09:01:07 EDT
I've tested this against a system with Intel 82801JI (ICH10 Family) HD Audio Controller [ALC262] installed. Tested against 6.4 all the way up to 6.7 with the front mic connected and can't manage to reproduce this.

Note You need to log in before you can comment on or make changes to this bug.